File Explorer can't read partition

Sorry, but can’t find a forum for MyCloud Mirror. Hope to get help here.

I have a NAS MyCloud Mirror drive with 2 partitions. Public (\ MyData(\ They used to be xxxx.172 but drive changed it’s ip to end in .246. File Explorer won’t allow me to enter new full path. Only allows me to enter 11 characters. When I look at ‘Properties’ it says file system is unknown. I imagine it’s defaulted to FAT so only 11 characters show. How do I change the info in the properties window?

Question Info

Last updated November 17, 2018 Views 6 Applies to:

Post a screenshot of what you’re seeing and where you’re trying to enter a path that’s restricted to 11 characters.

The path in the screenshot shows as more than 11, but that’s a leftover from when it worked. If I click on ‘Rename’ (shown) it highlights and restricts to 11 characters.


That is just the name, not really the path you want.
Just recreate two news ones and delete those

Gramps beat me to the punch.

Yep, delete both of those mappings and re-map using the new IP.

Right-click the mapping and select “Disconnect.”
Then click the Map Network button on the top toolbar (shown in your screenshot) and map the new location.

Once the map is successful and connected, you can then re-name the mapping to whatever you want.
It’s restricting you to 11 characters at this point because it’s a disconnected mount.

This is frustrating.

Delete (disconnect) worked fine. Went to Network and mounted ‘Public’ under (Z:). Trying to add another folder under (Y:) causes error ‘can’t find…’ Then decided to restart and got ‘cannot reconnect to network drive’ and all info in file explorer was gone.

I always have a problem trying to connect an anonymous login and a user login to the same box. You can try deleting your stored user credentials
tap the windows key once and type credentials