FastForward & Rewind in MPEG2 files


#1

Hi,

I’ve got a very annoying problem with my WDTV:

I use MediaPortal to record TV shows which are written to disk in MPEG2 format. Watching these files with WDTV works, but doing fast forward or rewind on them results in skipping “somewhere” in that file.

E. g. when I ff to 1:00:00 and then press play, it might play from 0:55:30 or 1:03:27. So skipping adverts for example is almost impossible.

FF & rewind works as expexted when playing the same files with Windows Media Player and VLC. I also tried it on a Pinnacle ShowCenter where everything works fine.

I’ve tried the following without any changes:

  • view the initially recorded transport stream

  • transcode it to a program stream using PVAStrumento

  • record with GB-PVR instead of MediaPortal

  • record with a different DVB-T stick

  • demux and mux files again

I’m running the latest firmware 1.03.01.

Any idea would be highly appreciated as this makes the device almost useless for me!

Thanks,

Norb


#2

this happens with everything the ff and rew functions arnt that great, just try ff/rew on a lower speed when you know the time is coming up … what i do is ex: ff X16 to 33 min and then play then ff X 2 till the desired 35 min


#3

Thanks for the tip!

But unfortunately it doesn’t work in my scenario: Event when ff-ing at only double speed, WDTV will continue playing from a wrong position as soon as I press “play”.

When I tried your suggestion WDTV still jumped back several minutes…


#4

YES! YES! YES!

I’ve been having this problem forever and I’m glad someone else is too.

I use Hauppauge’s WinTV 7 software to record over-the-air TV broadcasts in HD.  It saves them as mpeg2 files.  They play and fast forward and rewind fine on my computer, but as soon as the mpg hits the WD TV HD device, I have exactly the same problems as TheNorb describes.  It is VERY VERY frustrating and nearly defeats the value of the device.

I have tried post-processing the mpg file with numerous tools prior to transferring it to the WD TV HD device, but no effects.  (In particular, VideoReDo is awesome in fixing up mpg files, but doesn’t prevent the problems with searching in mpg files; neither does mpg2cut2; neither does Canopus Procoder; neither does SUPER; etc., etc., etc.)

Could someone at WD comment on this?