Failure To Install/Uninstall - Can't Open WDSmartWare


#1

I have a 1TB MyBook Essential that I have had installed on my computer once before.  I backed up my hard drive but between then and now, I had to use a system restore on my PC to fix a few issues.  I went to back up some new files today and it said I had to install WDSmartWare.  The install screen got stuck on the “25 seconds remaining…” part and finally Windows popped up an error message, stating an error had occurred and WDSmartWare.exe had to close.  I unhooked the drive (safely), closed the running programs and tried again.  This time when I double-click the installer, it says an error has occurred right away.  I tried to uninstall the program to give it one more go and halfway through the uninstall, it gives me a ‘fatal error’ stating it can’t be uninstalled because it was never really fully installed!  Argh!  How can I proceed?


#2

Unable to install  WD Smartware.  Error message: Windows cannot find path  C:\Program Files\Western Digital…