Failing Drive

I have a MyBook Essential 1TB drive that is trying to fail. I have a video production company, and use MyBooks for backups – this is drive number 13 for me. I have been using them for years with no problems until now.

   I’ve had it for several months, have backup up three projects on it. On my last one, a couple of weeks ago, it was a bit wonky coming up but then it worked fine. (By ‘wonky,’ I mean that it kept trying to re-install software.)

    Today was a total no-go. It would sit there and spin, making the sound of of a quiet but nonetheless upset snake, and it would not talk to my machine. I went on the knowledge base and read that I needed to un-install and re-install the WD software, but when I went to do that I found that the software was not present on my system. I thought that was weird, considering that I have backed up three projects already. so I tried my other machine, which  did have the WD software showing up, and the drive appeared on that machine. Sort of.

   Two of the three folders read as empty. The WD software software is corrupted. The drive showed up in my diagnostics in name only, no data is available. Trying to format the drive got no response, checking it for errors or fragmentation is not possible.

  I have not called WD because, quite frankly, I have no idea when we got this thing. We tend to snag them on sale, because we know that we will be using them eventually. At the rate we’re go thru data, a TB just aint what it used to be…   ;-) 

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support