Failed MyPassport 2TB drive - advice/guidance appreciated


I’ve just had a failure on a 6-month old 2TB MyPassport drive, and I’d appreciate some input and guidance as to what may have occurred and whether anything may be recoverable off it (nothing critical on there, but some stuff I’d like back and others that’ll take a lot of work to recreate).

I was copying some files to it last night, and then suddenly the copy went from “2 minutes remaining” up to “3 hours remaining” and after that just stopped. I tried to cancel the copy, at which point the laptop froze up then rebooted.

Current situation now is when I plug it into my machine it sees a drive, but lists it as “Local Drive” rather than MyPassport and can’t access anything on it (it either just locks up explorer or says it’s inaccessible and do I want to format it). If I plug it into a brand new machine it does a driver install for WD MyPassport and WD SES (or something like that), but then only the unaccessible local drive appears. The WD Quickview and Smartware software don’t see it at all :frowning:

Is this going to be a hardware failure in the unit somewhere, or is it corruption of the drive partition or something like that? And either way, what is the best route to look to get the data back? The drive is under warranty (purchased from Amazon), but I’d like to get as much off it as possible before any replacement is sought. Or failing that get it repaired rather than replaced, as it’ll be a pain to reconstruct all the data (and some will be unavailable by now).

Any help available would be appreciated!

Did you try using a data recovery software?

Maybe the software will allow you to retrieve the files so you can replace the unit.

I did - they either don’t see it at all or just hang if pointed at the drive letter windows assigns it.

Am awaiting a call from a WD support engineer (due in a few moments) to see what we can see with it. The computer management console under Win7 also hangs when you select disc management with the drive attached (sits there with status of “Loading disc configuration information…”).

You can also try booting from a Linux Live disk. Sometimes tha gives access to data.


Thanks for the idea - I did try it and it’s not even detected at all (using a USB install of Ubuntu 14.02 freshly downloaded).

Had the call with the WD tech support, and the consensus after some trials is the device has had a hardware failure (the overall drive is visible to Windows, but the volume within it is not and the diagnostic tools and Windows Drive Management both fail to see it).

I have one or two more things I want to try, but over the weekend it’ll be RMA’d and sent back to WD for replacement. Then the long slog of reconstructing the 1TB worth of data that was on it will have to begin.

But I must say whilst it’s disappointing to have the hardware itself fail after only 6 months, I can’t fault the responsiveness and customer service received to date. A shame the warranty doesn’t cover data recovery, but I don’t think anyones does these days.

Thanks for the inputs, but the last trials haven’t worked, so looks like a terminal hardware failure.

So it’s an RMA job, drive will be packaged up and sent off over the weekend, then the reconstruction task will begin again. 

I have however also decided to buy myself a NAS box to have in parallel with this as a central storage solution to stop this kind of thing happening again (will probably be a MyCloud 4TB I think).

Hi DarrenHill,

I’m also having similar issue like you had.

Can you tell me what recovery you used ?

Do we need to purchase , or anything we can get it from internet ?




Unfortunately I couldn’ find any software which would read the drive. All the ones I tried either didn’t see it at all, or tried to scan the drive letter that Windows had assigned to the “local drive” and just froze or hung. The input from the WD service engineer was that the “local drive” assignment was because the computer could see the top-level drive electronics, but the actual volume itself was not readable probably due to a physical failure.

In the end I just RMA’d the drive and sent it back without any data recovery. Fortunately I can rebuild most of what was on there, and the bits that I cannot are stuff that’s nice to have but non-critical. Sorry…