EXTREMELY nervous about My Book Studio edition external hard drive failure. Please Help

Hi everyone.  I’m new here and i’ve got some questions about what is going on with my My book.  I’d really appreciate any feedback you guys can give me with this problem.

Okay so I’ve had my My book Studio edition 500GB hard drive (for Mac) for close to 2 years now and everything was goin great until this morning.  I was in the middle of saving a photoshop file when my computer froze up.  I went to the normal procedure of holding the power button down on my laptop to reboot but when it was finished i noticed the lights sort of blinking on and off on the Drive.  It was a blinking pattern i’ve never seen before and it wasn’t makin the sound it normally makes.  It wasn’t making any sound at all.  So i unplugged it and plugged it back again and the light came back to normal but it wasn’t being recognized by my laptop and there still was no sound. I dunno if just overheated and the fan stopped or what the case is, but i have no clue.  It’s still not being recognized and the “mybook icon” is not showig up on the desktop.

I’m really scared because my whole life is on this thing.  I have some stuff backed up but most of it is all on there.  I am really afraid of any data being unrecoverable or lost.  I’m planning on sending it out to see if data can be recovered, etc. but if anyone can please give me any feedback to somewhat ease my mind (IF Possible right now)  i would be so thankful.

Thanks in advance.

I don’t know much about Macs but probably some partition information is corrupt. I’ll send somebody a PM that is up on Macs.


1 Like

Thank you so much, Joe.  I’d really appreciate that comrade.  I’m a nervous wreck over here lol.

I am sorry I cannot be an awful lot of help (as I have the identical hard drive, very similar problem) but wondered- have you checked the drive in Disk Utility?

I will tell you what I found and what I have already tried, in case it does anything to helping you get further with this worrisome issue (I too have far too many important files on it):

  1.  I started up my daisy-chained WD drives (1x1TB, 3x350GB, 1x250GB and the 500GB one) which are coupled with a single iTB Lacie which are all nicely lined up, adequately ventilated and only used once or so a week for a period of an hour or so as I pull data from them (I make/edit video) before being unmounted and powered down (lost too many drives so am a little, erm, consequential about it) after a two week break.

  2.  Saw all drives BUT the Studio Edition mount.

  3.  Noted the light was not on so pressed the button once.  Nothing.  Pressed it again and still nothing

  4.  Unplugged and replugged it after 30 seconds (powercyle) by removing first only the power cable, then all cables (3).

  5.  Shut down and then, after a minute, restarted the MacBook Pro to force a “surge” through (this has been the only thing to work in the past for another WD drive).

  6.  Unplugged the drive from the chain and moved it to direct feed from the mains (no extension cable) and directly into the Mac (as recommnended by WD themselves).

  7.  Tried another MacBook Pro (usually on OSX 10.6.8 but tried OSX 10.5.8 on the other Mac).

  8.  Tried a different Firewire (800) cable.

  9.  Tried the restart of the drive- unplug, wait, replug power cable, press button, wait for full power-up, plug in cable at drive end and then only at the Mac end.

  10.  Tried Disk Utility in between most actions and cannot mount it (but CAN see it most times, but NOT all times!) for love nor money.

  11.  Reintroduced it to the group and it sill wont mount but is still visible.  

Now, I use mine sparingly, never rough, no reason I can think of that it’d not work.  I understand your pain and worry only too well.  No comfort to you, I know…  But do check if you can do a verify disk and repair disk from within Disk Utility and what happens then.  Also see that you have tried some of the above things as you might get lucky where I did not.

All the best!