Extracting data from disks, after Sharespace 4TB Raid 5 network controller died


I have a 4TB Sharespace configured to Raid 5. A couple of days ago, it stopped showing itself on the network,

still returning a ping, but invisible to the network, what ever I tried.

I contacted the local WD dealer, and they said I still have Warranty, and they can replace the entire thing. The problem is that I really need some of the data on it, the disks are probably healthy, but there is no way I can access the data.

A technician told me it’s possible to extract data, by pulling out the disks, and connecting them one by one, straight to a PC, then Burn a boot CD of Data LifeGuard Diagnostics, and use this utility to extract data from single mounted raid 5 disks…

I’ve read about Data LifeGuard Diagnostic, and it seems it’s only for testing the disks ?!

is there a way (assuming the disks are healthy) to extract some data from them?

Thank you,


This drives will not be read in a Windows computer, the file system in this drive is EXT -3 or EXT -4, furthermore, WD Data Lifeguard Diagnostic is a testing application, as you stated, it will not help you.

If you connect the drive in a computer that is running  Linux, you might be able to access the data.

@oxter: one of your colleagues provided detailed step-by-step instructions on how to do this from a ShareSpace that had been running on RAID-1 in this forum.

However, up to this day, I have not seen the equivalent for a RAID-5 array. I would like to urge WD to provide this type of instruction for RAID-5 as well.

sigh… thanks.

I dont have access to a Linux machine… I guess I’ll give up (I had 98% of the data backed up, but those missing 2%

hurt a bit :wink: )

If I had a Linux machine, would I need a special software to extract the data, or would the drive be recognized by

the OS, and I would have access to it?

Thanks again,


The problem is that it is not possible to extract that data from just one hard drive.

In RAID-5, the files are spread over all 3-4 drives. In other words, the file “ImportantStuff.doc” is not located on just 1 hard drive but actually on at least 3: 1 bit on drive 1, the next bit on drive 2, the xor of those 2 bits on drive 3  - and so forth.

So if you had access to a linux machine, you would have to attach all 4 drives to it and mount it as raid-5. Unfortunately, WD refuses to provide a step-by-step tutorial on how to do this and which settings one should use.

By the way, if you have access to any desktop machine, you can just boot it with one of those “boots from DVD” Linux discs that pretty much every distribution provides free of charge. That will make that desktop PC into a Linux PC without ever touching the hard drive (it won’t delete Windows or even alter anything on the hard drive).

I was able to recover my data from a raid 5 sharespace that was bricked by the firmware updated.  I posted a step by step tutorial in another thread which is at the following link:


It worked for me and at least one other person that I know of!

Good luck!

1 Like