External Network hard disk drive not showing / connecting 10.7


Does anyone have an idea why, after upgrading to MacOS 10.7 the drives will not show in finder or work with Time Machine?


Is the drive compatible with the new Mac version?


i updated to to MacOSX10.7 and now when I try to connect to my network WD MyBookWorld drive, i get an error message that says the version of the server is not supported

neglected to mention in previous post that I tried the firmware update from 15 June, but it is for USB disks, not network

I have updated 3 of the 4 Macs we have to Lion.

After that the two Synology servers we have were not visible anymore. With a tric on an Apple forum we could made them visible and acessible again. 

Same problem with a number of 2,5 inch external harddisks. I have 3 1TB Seagate EXTERNAL harddisk who were not visible on the updated Macs, only on the ‘Snowleopard’ Mac. Some 500GB Freecom disks worked fine just as some 1TB LaCie disks. So yesterday I bought an 1TB WD Passeport SE as I believed WD works fine with Lion (because there are 14 2TB WD disks in the servers). But also this disk is not visible.

I trust Seagate as well as WD will fix this problem (together with Apple I have learned from the Seagate website) asap.

The tric used for the Servers doesn’t work for external harddisks.

By the way, I do have a Time Capsule but there were no problems there.


Thread moved to WD Network Products : My Book World Edition.