External FTP with My Cloud not working with IE and Edge browsers

I have 4TB MyCloud with latest firmware.
External FTP with My Cloud is working fine with Google Chrome, Opera and Firefox browsers and with FileZilla.
But it is NOT working with IE and Edge browsers as well as WP Updraft Backup plugin and All-in-one WP Migration FTP plugin.
What is the problem and how can I fix this?

It appears Microsoft changed the way one accesses FTP sites in later versions of Internet Explorer. Try the following in the Internet Explorer address bar using the correct FTP Server, username and password for the site your trying to access: ftp://username:password@ftpserver.

Supposedly Edge doesn’t support connecting to FTP sites like Internet Explorer does. You can either use Internet Explorer or use Windows File Explorer in Windows 10 using: ftp://username:password@ftpserver.

Hello Bennor,
Thank you for the fast response.
The connection problem with IE and Edge is not important, but WP Updraft Backup plugin and All-in-one WP Migration FTP plugins are extreemly important to work for me, so is there any suggestion for this issue.
I have linksys router with ports 20, 21, 22 forwarded.
Unfortunately there is no any usable info what is the connection problem as you can see in the attached picture.

Switch on the PASSIVE MODE, the last option in your screenshot.

Helo Jeorg_A,

It doesn’t matter, it’s the same with or without Passive Mode checked.


what happens if you remove the FTP:// in the hostname? IP-Address only without leading ftp:// ?

BTW: where is your screenshot from? I think this is not Windows 10 but a program, right?

I tried your posted link but no response. Is it your My Cloud device? Have you entered a so called port forwarding role in your router? If not, you have to open this port forwarding in your router:

External Port 21 to Internal Port 21 (data type TCP if you need to enter this) to Internal

Please open Port 21 only, not Port 20 too.

Who or where is the Word Press site that is using those plug-in’s hosted? On a web server on your local network or on a remote hosting site? If on a remote site, does that site allow outbound FTP connections from the Word Press interface to a remote FTP site? Can those plug-ins access other FTP servers other than the My Cloud?


Thanks to everyone for the help.
The problem is solved by removing the “ftp://” in the host name and forwarded only port 21 and port range 5000 to 5099 TCP.
I think the topic should be closed with successfully solved.


nice to hear, you can set the “Solved” flag by yourself. :+1: