External drive does not show in Disk Utility, but does in WD Drive Utilities

I had the drive attached to my mac, then the mac interface froze. So I rebooted. Now I cannot find the drive anymore.

What doesn’t work:

  • does not show in Finder
  • confirmed that external drives are visible in Finder
  • does not show in Disk Utility
  • I tried rebooting
  • I tried detaching while powered off, reattaching all cables before power back on
  • I tried detaching while powered off, booting up again, then attaching the drive later.
  • I tried all of these that I could: https://support-en.wd.com/app/answers/detail/a_id/12455
  • I tried everything suggested on the internet.
  • It also does not show on another Mac (whatever I try of the above)

However, what I do know about the drive:

  • LED light is on
  • Drive is spinning
  • Drive is working (I can hear it, constantly working)
  • I cannot detect any active programs using the drive.
  • Does all of this on another Mac as well (!)

MOREOVER:

  • it DOES show up on the WD Drive Utilities program!
  • this program shows the drive with the size
  • It shows me the serial no and firmware no.
  • It lists ’ no volume’ though - which should be incorrect.
    Also, I can use the WD Drive Utilities to:
  • check the SMART status of my drive (check)
  • do an advanced scan of my drive (check)
  • do a full scan of the drive (ongoing)

However, whatever I try, it does not show again in Finder or the Disk Utility. I cannot use it.

My conclusions:

  • because the drive is spinning and can be scanned etc, the drive itself, the cables and the primary device interface are working fine.
  • if the only problem would be the volume/partition, I should be able to reformat using Disk Utility; so that cannot be it.
  • I have no clue whatsoever what the drive is busy doing constantly whenever it is plugged in now. It is not a continuous or repetitive sound; it changes, fluctuates, etc. Sounds something like you would expect from Spotlight doing an index on the drive.
  • What is going on here that only (!) the WD Drive Utilities program can see it? Is it bypassing the OS?

I don’ t know what to do. Files on there are sacred!
Looking forward to hearing from you.

EDIT: well, turns out the indexing was indeed spotlight ( mdworker’ process) running in background. And that while WD Drive Utility was still performing the ‘full scan’ of the drive, it suddenly showed in Finder. Don’ t ask me how. Hopefully the above may help someone else troubleshoot.

Something very similar, all the same as above apart from while it is showing in WD Drive Utilities when i click on the “Run Drive Status Check”, “Run Quick Drive Test” or “Run Complete Drive Test” they either go blue and then immediately back to grey without anything else happenning, or stay blue for a few seconds then back to grey without anything else happening.
Any advice would be really useful as i have been rescuing files from a macbook pro that is on the way out and some are not copied anywhere else!