Expired Activation Code error


I am using a Sony Tablet with Android V3.2. After I installed the WD2GO app and entered the activation that had just been generated on my dashboard, I get an “Expired activation code XXXXXXXX (403)” error !! Please help

Try uninstalling the app and reinstalling it again.

Tried that too… Does not work…

You can try generating another code, however you will likely need to delete all the generated codes and do a factory restore (quick). Make sure your My Book Live is on the latest firmware, too, since we did resolve this in later releases.

Hi Laura,

Strangely the very same code later worked on my iPhone. Does not seem to be a code generation problem. The device has the latest firmware updated.

If your Internet Connection is intermittent, perhaps the code request didn’t finish completely until later. Generally you’ll receive an error, though, so I’m not sure why you got one. Maybe you typed 9 instead of 6 or something.

Aah !! I wish the problem was as simple as me typing 9 instead of 6 !! However tried generating a code multiple times - nothing works :cry:

It’s not working again? It may be a connection issue then. Have you followed our WD2go connection KBA? KB: 8526. Make sure you fill in actual DNS servers and not the router/gateway IP. Routers don’t always do the DNS re-routing properly.

Problem still persists !!

Currently we do have a bug in the 1.x-to-2.0 upgrade WD 2go did on Android. There is no issue for users who go from 1.x to 2.0.1 (current latest version of wd 2go), however for some people who updated before 2.0.1 came out there may be a corrupted DB issue. You’ll have to uninstall the WD 2go app and reinstall it.

It’s an activation code error, however yours may be related to something else. Would it be possible for you to send me logs? I’ll send you a PM with instructions.