EX4100 USB Drive Disappeared

My NAS auto updated firmware with My Cloud Firmware 2.31.195 and now my external USB drive disappeared. I will power down the drive and see if the external is recognized but I need this drive to be working continuously so I don’t have these problems when I am away from the drive for an extended period of time.

SOLVED - I spoke with tech support and they told me to reformat the external drive. I asked why and told them that the USB drive worked perfectly on a PC. They even told me to contact the drive manufacturer. I finally figured it out while tech support was on the phone. Seems like the NAS reboot cycle thought that the USB was removed without ejecting first. I figured that out because I unplugged the unrecognized USB drive and rebooted the NAS. Once the NAS was up I plugged in the USB drive and it was recognized. Seems like WD software guys need to work on having the NAS remember plugged in USB drives whenever the NAS reboots. This happened on an auto firmware upgrade.