EX4100 802.3ad (LAG) not working

I have 3 NAS devices (2 x WD, 1 x Seagate) on my LAN. All are on the latest respective OS. All 3 have LAGs setup in our SG350X switch. My PR4100 and my Seagate 4 port NAS connect to the LAGs without issue and show as 2Gbps. My EX4100, however, is setup as 802.3ad but only one port is active at a time. My Cisco switch shows one port of the LAG active, the other as a Standby Member. LACP is enabled (I’ve tried the LAG with it disabled with no change). I tried the same setup using an SG300 and got the same result. It’s pretty clear to me that the EX4100 doesn’t really support 802.3ad, but is, in fact, doing fail-over or something else, but it’s surely not honouring the LAG setup. Here are screen shots from my SG300 and from the EX4100. Thoughts?
sg300_lag

Hi @TubaOrNotTuba,

Please refer to the article My Cloud OS 5: Apps Page Stuck at Loading or No Internet Access Message:
https://support-en.wd.com/app/answers/detail/a_id/30011

If further assistance is needed, please open a case with our support team at the following:
https://support-en.wd.com/app/askweb

@Keerti_01, why did you send me to an article about Internet access when I’m discussing LAG functionality? My NAS drives don’t need Internet access 24/7 to function on my LAN. LAG should have absolutely nothing to do with Internet access, it’s a function of the 2 NICs and their drivers. As BOTH of my other NAS drives also have no Internet access 24/7 and their LAGs work fine, that tells me your drivers/firmware for the EX4100 are defective, but I doubt that would surprise very many people who own them.

Hello? Can you please revisit my post and help me solve 802.3ad not working on my EX4100?