EX4 has disappeared from Windows 7 Explorer Network

The EX4 has updated itself to 1.04.04.
That quite likely has nothing to do with what has happened, since my Seagate Business NAS has also disappeared.

I run Windows 7 Ultimate on several workstations, and have two Domain Controllers running Win Server 2008 R2. All computers are fully updated.

Everything has been running smoothly with access from any computer until two days ago, when both NAS objects disappeared.  I can tracert both, but I cannot even map either of them. Nothing has been done with either DC or any Windows 7 machine. Consequently, I am at a total loss in explaining what is going on, but suspect its a DC setting. Cannot find any errors with the DNS, or Active Directory settings.

Has anyone else come across this disaster?

I forgot to mention that I can open the browser connections easily. On the Seagate, where one has an Active Directory option, the attempt to make it a Domain Member fails even when the correct entries are made. Of course, the EX4 won’t allow both smartphone access and a domain membership, which I find abysmal.

Once more! I have two DCs, and I do not refresh Windows Explorer very often. So, going to either of them, I see that both NAS objects are shown, and, clicking on any folder within the NAS structure, opens them.

There is something weird going on! I cannot do anything other than tracert. One can see below, one computer has been contacted, and both NAS objects. So???


This is happening to me also as of Monday…

I have 2 EX4’s

While using Windows Explorer, One I can see fine, the other not at all.

Both dashboards come up just fine, they are performing backups to each other without issues.

I can remote desktop into another machine and see both devices fine. So this is specific to a particular machine. (Win 7 Pro x64 on a corporate domain, I am domain admin)

WD Quick view shows both devices. the mycloud.com shows both devices and lists all shares.

The only thing I can think of is that with one of them I tried connecting to Active Directory to test an issue I am having to see if the recient firmware addressed the issue, nope it did not.(I do not remember which device I tested on bit i believe it is the one not showing up)

The only other difference is the one not showing up is static IP (and listed in our dns) while the other is dynamic.

I will add more notes as I come across them.



I am not sure about the other persons issue but mine was being caused by a bad User credentials setting. I found this because by logging into my machine as another user account I was able to browse the device.

Windows 7 Pro x64

To fix it I had to perform the following…

Control Panel/ User Accounts

On the Left side you will see Manage your Credentials

I deleted the stored credentials for the device.

I was able to browse the device using Windows Explorer as expected.

1 Like

In the past, Credential Manager had caused the problem. However, there are currently no Windows credentials written there.

What I do, every time I have to log off or reboot, is to simply use Explorer and write \NAS active directory name. That opens each NAS and every folder thereon. Works until reboot.

Still does not explain why Explorer/Network fails to open the NAS objects, which, naturally, are seen in my DCs as computers.

Thank you for sharing what worked for you with the WD Community. Hopefully this will be able to help more board members later on.


One further proviso; saving files produces a screen with all of my computer’s drives, the three or four external drives I have (includes a tablet and a wireless drive), plus my networked computers, but does NOT include the NAS drives. So, saving to the latter requires an extra step.

This is why I regret the loss of the native inclusion of the NAS drives in the Network part of Explorer. Why it has happened is not traceable.