EX2Ultra won't remain connected long enough to complete backup

I am having an issue completing a backup from my Mac to EX2Ultra. Things worked fine for over a year, and I haven’t made any changes to the system recently.

My EX2 has been connected via ethernet to my cable modem, and I use Time Machine to back up my Mac to it. The volume appears in Finder, and I am able to use Finder to upload and download files to it. A couple of weeks ago, I started getting failed backups saying that Time Machine could no longer find the EX2. The backup would run for several hours, but at some point it would lose the drive and the backup would fail.

I thought the problem may have been the network connection, so I connected the EX2 to my Mac directly via a thunderbolt/ethernet adaptor. But I have exactly the same problems. It will remain connected and working for a few minutes to a few hours, but then the drive disappear and the backup is lost.

I have tried Disk Utility, and find that the Apple sparse bundle sometimes appears and sometimes does not appear as a volume.

I am able to back up to a different (not-networked) external drive using Time Machine, so it is looking to me like the EX2 is the problem.

Any suggestions?

Thanx!

Hi,

You could refer to the following links:

https://support-en.wd.com/app/answers/detail/a_id/24863

https://support-en.wd.com/app/answers/detail/a_id/14277

Thanks. Worth a try.