EX2100 Backup to My Book No Longer Works

After no problems for quite some time, my EX2100 now issues “backup failed” error when using my USB Backup jobs. I have ejected the 3TB My Book, removed the usb cable, rebooted the EX2100, and reattached the My Book. No success. I am running firmware 2.21.126 and have been for some time without issue. I have tried this on multiple shares with no success.

Any ideas?


When the My Book is attached, does the dashboard show the USB drive?
Is the My Book share created on the My Cloud?
Can you access the My Book using Explorer as a share on the EX2100?


Yes, the My Book is visible as a share on the dashboard (and from the web view app). That share was created a long time ago. I can access the My Book using Windows Explorer and access all the files.

This issue started a couple of days ago. I did a back up of my work files, which completed successfully. Then when I tried to back up a different share, it failed and every other share now fails, including the one that didn’t fail a couple of days ago.

I found the issue. Apparently the EX2100 uses more space on the My Book than just the simple sum of the files it is copying over. After deleting some duplicate information on the My Book, the EX2100 can complete the backups.

The question is why doesn’t WD create a backup routine with some brains that could just say “insufficient space?”