EX2 very slow transfer speed even with direct connection


I have read many community topics on EX2 speed issues, but can’t seem to find a solution for my problem. Even when transferring single big files (e.g. an avi or iso file with up to 8 GB), the download speed onto my computer is 10MB/s max, i.e. regardless of the connection type. I even connected the EX2 directly to my laptop’s (gigabit) LAN port, using the Cat. 5e cable that came with the EX2 and with WIFI disabled - but it still wouldn’t go faster.

The NAS is running in RAID 1 mode without encryption.
Changing the jumbo frame settings on the EX2 doesn’t make a difference, nor does changing the transfer rate setting from auto to 1000.
What else can I do?

Any thought or referral is appreciated!

Let’s clarify one thing first.

10Mb/s = 10 megabits per second
10MB/s = 10 megabytes per second. Equivalent to 80Mb/s.

If the second one is what you mean, and you have a fast ethernet connection (100Mb) than it looks fine.

If not, plug the cable on your network, access your NAS using SSH then run ethtool egiga0 considering that this is the name of your interface.
What’s the output?

Thanks for your reply!

I mean 10 megabytes/sec max. Judging by what I read in this thread and others, I actually thought I could expect at least 40+ megabytes per second from the EX2 (not just megabits), especially when connecting directly, but also from within my gigabit ethernet environment.

root@WDMyCloudEX2 root # ethtool egiga0
Settings for egiga0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
Transceiver: internal
Auto-negotiation: on
Link detected: yes

Your interface is negotiating at 1Gb full duplex so when transferring big files you should be getting up to 125MB, or at least 90MB.
Have you tried transferring your files from another computer?

So at least I’m not expecting too much!
I unpacked an all new Cat. 5e cable that came with new gigabit LAN equipment a couple of weeks ago, and used it to directly connect different computers to the EX2.
I’ve tried three different laptop computers now. All the same: Upload and download speeds do not top 10MB/s.
While copying, I had a look at the Mycloud dashboard. RAM usage is stable at 50% while copying, but the CPU is running at 100%. Does that indicate anything?
Any further suggestions?

That’s weird. Honestly I don’t know what could be happening.

Too bad! Thanks for your time and help anyway!

I might go for a factory reset but may have to get myself another backup storage for my data before that.

Actually let’s ignore the cpu thing and try this:
Disable your anti-virus and try a new copy. It could be scanning the files while you copy them.

Still using a direct Cat. 5e connection between computer and EX2, disabling my anti-virus didn’t affect the transfer rate at all. It’s still 10MB/s, 11 tops.
As a matter of fact, the same computer both downloads and uploads big files at 25+MB/s from and to my other computer (with both using wifi and anti-virus enabled).
I think the problem lies within the EX2 but I don’t remember changing anything that may have led to this…

Yeah, I think I’m out of options too

I have the same speeds on my EX2. But I also have only 10MB/s on my Synology DS218 also. In my case, the Synology software lets you look at the network characteristics and it showed my gigabit network was only transferring at fast ethernet speeds (100Mb/s). Could be an issue with your network (cables, terminations, etc).