MyCloud EX2 extreme low file transfer rates on Gigabit Router

Hi guys.

Recently I’ve bought a My Cloud EX2 and since the installation I’ve been experiencing very (painfully) slow file transfers between the My Cloud and my PCs, as well as between My Cloud and the USB drives attached to it (sometimes I plug in a WD My Passport 2 TB). My setup is as follows:

  • WD My Cloud EX2 8 TB in RAID0, latest firmware available installed (1.04.05), factory settings
  • Router ASUS RT-AC68U (4x Gigabit Ethernet ports) WD MyCloud EX2 8 TB, connected to the router’s Gigabit port through CAT 5e network cable
  • WD My Passport 2 TB, eventually connected to My Cloud’s USB 3.0 port
  • Laptop running Windows 8.1, Gigabit Ethernet network adapter, connected to the router via CAT 5e cable (actually, the tests are performed using two different laptops, both from Asus)

In various setups I perceive extremely low file transfer rates between my PCs (all wired to the router, Gigabit ports) and the My Cloud NAS. The maximum transfer rate I get is about 11 MB/s, most of the times averaging 5 MB/s. Even whenever I use the My Cloud web interface to start a backup from WD My Passport 2 TB to My Cloud EX2 (via its USB 3.0 port), the backup operation takes 72 HOURS to complete! (considering the files are being transferred directly via USB to the NAS!)

So I was wondering if this is normal or my My Cloud is having some major issues. Since it has the ability to connect to the router via a Gigabit port (i.e., up to 125 MB/s of file transfer rate) I expected REALLY much more than just 5 or 11 MB/s when transferring my files, which makes me much worried. The network LED behind My Cloud is blinking GREEN, indication a successful Gigabit Ethernet connection to the router.

Below I put the links for some snapshots I’ve made of the tests setup:

  1. Using the Windows app ‘LAN Speed Test’ I transferred 2 chunks of about 200 MB to the NAS; avg transfer rate (writing): 11.5 MB/s
  2. Using 2 different PCs to copy the files to My Cloud, using Windows 8.1: the file transfer operations presented strange ripple effects , with the speed ranging from about 11 Mb/s to 0 Mb/s in a “teeth” waveform, resulting in a general average of 11 MB/s.


A:  Setup with LAN Speed Test

B:  Copy of files - Windows to NAS (avg 11 MB/s)

C:  Copy of files - Windows to NAS (avg 11 MB/s with ripple effects)

D:  Copy of files - Windows to NAS (non-zero ripple effects, avg 5 MB/s)

E:  Copy of files - Windows to NAS (avg 10 MB/s full with ripple effects, with peaks at 20 MB/s)

I must emphasize that the Asus router I’m using is brand-new and it was thoroughly tested with other devices, performing perfectly well (one of the best models available on the market); when I transfer files between the 2 laptops through GbEthernet I perceive about 50 MB/s or more of file transfer rate. I’ve also made the My Cloud tests on a Cisco E1200 (which is not Gigabit Ethernet, though), but the results were always the same: very low speeds, almost zero, with the very same ‘ripple effect’ perceived.

A final remark: today during the day I’ve left the My Cloud to make a copy of my files; at the end of a  12-hour period  it had copied about  455 GB , which means a  10.5 MB/s average transfer rate.

Could you please help me clarifying this matter? Thanks a lot!
Kind regards, 


1 Like

This has been discussed before, however here is the first thing you should do.

    • On the laptop that is connected to the router via cat5e ethernet open the control panel and go to “Network and sharing center” (This is for windows 8, on Windows 7 I think its called Networking).
    • On the left side click where it says “change adapter settings”.
    • Right click on the WI-FI adapter and select “Disabled”

Confirm that the Wi-Fi adapter is truly disabled.  Now then test your file transfer again.  If the transfer speed is much improved then come back here for a more permanent solution.  If not we’ll need some more details about your network config.

Oh yeah, and we can also talk about the USB speed as well.


Hi, Vertech1. Thanks for your reply.

Indeed, there are plenty of other discussions in the forums about the issues I describe here, but none of them helped me out, even though I’ve tried to follow the numerous suggestions (change network cables, update firmware, factory reset, disabling the My Cloud’s sharing services, and so on).

Concerning Windows wireless adapter, actually I had already disabled wireless networks through the switch on Windows Charms bar. Nevertheless I followed your tipe and disabled the Wireless adapter in the Network Adapters panel. It didn’t change a thing, though. For what’s worth my Ethernet adapter is a Realtek PCIe GBE (onboard on a Asus N46VM laptop).

During the day I made some other tests and I’ve noticed the same slow performance as usual, in the following scenarios:

a) Backing up from a WD My Passport 2 TB disk connected to My Cloud’s USB 3.0 back port (backup through My Cloud’s web interface setup) – total of 556 GB copied (relative to 65 560 files) during 22h, resulting in an average speed of 7.2 MB/s. Even though it is indeed a very huge number of files copied, it just doesn’t justify such a terribly slow performance using USB 3.0 port and another WD device. (when I had to copy such content from My Passport to my PC via USB 3.0 port, this would take long hours but never close to 22h).

b) Copying 1 file from Windows to My Cloud – 2.1 GB movie, average transfer rate < 10 MB/s (with ‘ripple’ waving).  Snapshot here

c) Copying 1 file from one My Cloud’s Share Folder to another Share Folder (both on the same device) – 2.95 GB movie file, top transfer rate 5.5 MB/s, averaging  4 MB/sSnapshot here

And I must stress out that during the performance tests the My Cloud device wasn’t being used by any other application/peripheral – it was solely used at the moment for each unique test.

Any thoughts? Maybe I’m lucky and this is a faulty unit?

Thank you for the help. Regards,


1 Like

Well, it seems you knew where I was headed with the WiFi business…

I would have to ask how you setup the unit in RAID0?  It comes from the factory defaulted to RAID 1.  I’m wondering if somehow the RAID 0 array is not properly formatted and that is killing your transfer speed.  Of course I am assuming that you purchased the unit with the two 4TB drives already in it.  If you added the drives yourself then the question becomes what type of drives are installed in the unit?

1 Like

The unit I bought is this one, from Amazon Germany (it’s been about three weeks):

It’s an 8 TB My Cloud EX2. I configured it to RAID0 using the native web setup so as to achieve the 8 TB capacity (that’s the main reason I bought it), since I have already backup units so I wouldn’t bother losing RAID1’s mirroring (4 + 4 TB).

Do you think maybe it didn’t format itself correctly ? Should I try to re-format it to RAID1 and then back to RAID0 again to verify?


I’ve just connected the My Cloud directly to my PC’s Gigabit Ethernet port (always using Cat 5e cable) to give it a try. The Wireless adapter is still disabled; the backside LED is blinking green on My Cloud. My Windows Ethernet connection is accusing 1 Gbps Ethernet connection. I’ve even forced the parameter ‘Link Speed’ to ‘1000’ on My Cloud’s dashboard settings and all I’ve got transferring a 700 MB movie file is this: 10 MB/s transfer rate average , as always. Nothing changed yet. Picture of test is below:

Any guess?

Thanks for the attention.

1 Like

Well, it appears you have ruled out nearly everything.  So here are the last few things I would do before I called it a defective unit.

1.  Confirm that the cable you are using is truly Cat 5E or better.  In fact, as I have had several bad cables in the past I would go ahead and get a Cat 6 cable and try that.

  1. I would also log in to the UI of the drive and take a look at the CPU usage.  It sounds like you are loading the drive up with a lot of files and the CPU may be maxed out trying to index and catalog all of them.  If that is the case I would consider turning off the media player function to reduce the load and test again afte rthe cpu usage drops. 

Keep in mind that if you put a lot of pictures on the drive it will take a long time for the unti to build the index files etc…  I currently have about 2TB of pictures, movies etc… on my drive and it took it about 3 days to finally settle down.  Having said that I never saw anywhere near the performance hit you are showing in your graph. 

One last thing, when you mapped the drive did your antivirus software start scanning the drive?  If so, turn that off as well. 

1 Like

Well, I’ve finally figured it out! First I’ll answer to your suggestions and then I’ll explain the steps to solve the problem.

  1. The cables are truly Cat 5e: I’ve used several different cables to ensure they weren’t the problem, including the original Cat 5e from the Asus router as well as the My Cloud’s. So, ruled it out.

  2. The CPU usage is always OK (off course, whenever the NAS is not being used). Also, the media player function was always off, as well as the other unused sharing/discovery features.

  3. The issues of transferring a monstruous number of files and the indexing operation could be an issue, but as seen as I’ve waited for a few days from one massive copy to the other (I’ve been doing this for two weeks so far), this wouldn’t be the matter either. Also, first of all I ensured the CPU activity was 0% and then I’d proceed with the transfers.

  4. The network mapping was always OK, with or even w/out the antivirus/firewall enabling – they were always well mapped (I tried both the network mapping and the direct LAN IP).

Having said that, here I present you the steps I took to arrive to a definitive solution.

STEP #1: RAID1, no encryption

Here, I re-configured the NAS to RAID1  setup, no encryption  (via My Cloud dashboard settings) and proceeded with a file transfer to the NAS (using a ~ 2 GB movie file, copied from Windows 8.1 to My Cloud through GbEthernet via Asus RT-AC68U router, Wifi disabled). As you can notice, the transfer rate went incredibly up, reaching up to 60 MB/s and averaging 51 MB/s!!! (all other ‘variables’ equal, such as cables, network adapter settings, files to be copied, etc., as before).

Snapshot here

STEP #2: RAID0, no encryption

Then, I set up the NAS to RAID0 , still with no encryption. This time, I got transfer rates averaging 57 MB/s! I’ve even got peaks past 75 MB/s…

Snapshot here

STEP #3: RAID0, with encryption

Finally, just to ensure I set up the very same RAID0 , but this time using the encryption option displayed on the HDD array selection screen of My Cloud dashboard. Look at what I got: the same very slow speeds as before, averaging barely 8 MB/s!!!

Snapshot here


It wasn’t the cables, nor the router, nor the NAS settings, nor the network adapter, nor network mapping, antivirus or anything else. The problem is the RAID ENCRYPTION of My Cloud , which unfortunately is preventing to reach high transfer rates. It is blocking the write operations on the disk, i.e. the bottleneck.

Just to give an idea, today using RAID0 w/out encryption I’ve copied about 170,000 files in a total size of 1.25 TB; it took me about 16h to do so, resulting in an average transfer rate of 23 MB/s. Considering the huge amount of files, I find it very reasonable (it’s more or less what I’d get using USB3.0).

  RAID0, no encryption

Therefore, with the transfer rate problem sorted out, now the big question is: this encryption issue is a bug in My CloudEX2 or I have in hands a defective unit? Since we can’t use this essential feature it will disappoint tons of users out there (myself, for example).

It’s something like: you have a car equipped with airbags, but they can be activated only if decide to you ride the car under 40 km/h; if you want to drive at 120 km/h you won’t be able to use the airbags. Either you use it high speed or you use the safety/security feature.

Any thoughts on that?

Thanks. Regards,



My first thought is I wish you had mentioned that you were using encryption before…  LOL  (If you did I definitely missed it.)  Encryption is definitely going to slow down transfers due to the requirement of the processor to read the data, encrypt it, then write or transfer it.  Unfortunately I do not believe this is a bug, I just think that WD chose to emplement encryption with an underpowered CPU.  The CPU is simply not up to this task, and cannot maintain a decent transfer rate with it enabled.  I personally do not use the encryption function so I cant say for certain that your unit is defective or not, but I would guess that it is not defective, it just cant perform encryption at the rate you require.

As an alternative to encrypting the whole volume, have you thought about creating one smaller volume for sensitive files that require encryption, and another un-encrypted volume for the bulk of your media?

1 Like

Yeah, in fact I forgot that I had checked this option in the RAID setup. Anyway, it’s solved.

But I appreciate your help as well as this last suggestion, to create a small volume just for the most critical files, I’ll give it a thought. Not that I have top secret files to store, but in an eventual, unlikely situation of getting my NAS stolen or lost it would be really reassuring to have my files encrypted so no one would be able to easily access my personal data.

Thank you so much for your efforts helping me out, Vertech1. Kudos.

Best regards,