EX2 Ultra - No email field for user setup

My EX2 Ultra has no email filed when I setup a new user.

  • I am trying to troubleshoot an invite that ins’t working.
  • Oddly, I created a new user using the same username as another because that user (and other users) show up in the Mac Finder, but not in the users list in the EX2 's webpage backend (strange).
  • The new user has an email attached for the invite to send, that I didn’t even type in. It probably got it from the same previous name.

The point is, I am trying to establish new users and there’s no email field at all like I see on others’ posts and the WD support pages. So I can’t assign an email address for a user and invite them even if I wanted to.

Using OS 5

Welcome back @tangierc to the community!

Are you trying to setup a user locally or a My Cloud user on your EX2 Ultra? I’d think the latter is where the email comes into play.

#WDUserRewards

It may help to post a screenshot of what you are seeing so people can better understand.

Have you enabled Cloud Access under the Cloud Access tab on the Dashboard, then selected the newly created user and click on the Invite button for that user?



See the subsection Enable User Cloud Access at the following WD Knowledgebase Article link:

My Cloud OS 5: Add Users and Enable Cloud Access
https://support-en.wd.com/app/answers/detailweb/a_id/29448

Also, there is a dedicated subforum for OS5 EX Series where users of the EX2 Ultra may be able to assist.

OS5 EX Series
https://community.wd.com/c/os5/my-cloud-ex-series/255

1 Like

There may be a host of connected things here. I see your point. I never realized they were exclusively separate; the local account and the cloud account. I established local accounts a long time ago for coworkers in our office and then gave them cloud access. It seems that you’re saying I can have local accounts that completely differ from users that have cloud access. I’ll keep that in mind.

  • Cloud access has been on.
  • When I try to establish a new account in cloud access the prompt says the user (with that email) already exists, but there’s no indication of that anywhere in the administrative pages of this device.
  • I tried setting up a new account with an email address I know hasn’t been used (another one I have), and that yields an error (image attached)
  • It’s really strange additionally that all of the local users visible in the Mac Finder are not visible in the user section of the backend. Perhaps this is a bug and I am unsure how to fix it.

Screen Shot 2022-09-17 at 2.27.23 PM

After seeing that error code and you are in fact connected to the internet I presume, you may want to consider contacting the WD Technical Support team:
https://support-en.wd.com/app/ask

#WDUserRewards

Couple of possible separate issues to troubleshoot it appears. First ensure the date/time and time zone in the My Cloud Dashboard are correct. Is your local network router/firewall configured to block internet access for the My Cloud EX2 Ultra? What does the Connection Status indicate under the Cloud Access tab in the My Cloud Dashboard?

  • Date/time and zone are correct
  • Router/firewall aren’t blocking anything. I am able to get in remotely from my phone.
  • Cloud Access is on and connected.

Thanks.

Yes, I may have to reach out to them. Has anyone had issues with services or field being unavailable if one drive is bad? I need to replace one drive and I have it’s new replacement here ready to go. I was just waiting for someone to log in and get what they need first.

You may be wondering why I didn’t mention that drive from the start. The reason why is that I have been able to get in remotely using my credentials without issue to the drive and unless this is a truly unique setup that hinders a lot of functions (I’m not a novice with RAIDs, NAS, networking, and such) one drive being down shouldn’t disable services or features. That would be horrible and certainly isn’t detailed in the manual if so. If it does, then shame on me for not catching that.

1 Like

One can try performing a System Only Restore or a 40 second pin reset (if you haven’t done so already) to reset the My Cloud back to factory defaults. No user data is erased or destroyed. In some cases a reset can fix certain weird issues with My Cloud devices.

My Cloud OS 5: How to Restore To Factory Default Settings
https://support-en.wd.com/app/answers/detail/a_id/29441

My Cloud OS 5: Pin Reset & System Only Restore
https://support-en.wd.com/app/answers/detailweb/a_id/29445

WD had a support article explaining how to delete or remove a MyCloud.com account but they have apparently taken that support article down.

  1. I did a system only reset and that seemed to get rid of the error code 409
  2. Adding new users locally still doesn’t offer an email field like I’ve seen in others’ posts.
  3. Drive status went from bad to good after system only rest!!! Something that’s very disconcerting is that before the reset, the unit reported one drive as failing and the red LED indicator on the outside was on. So I bought a drive to replace it. Since the system reset, there’s no mention of a problem with the drive on the dashboard and the red LED is off. This is upsetting because if a drive is faulty it should be faulty; not because of some system reset. So was money spent on a new drive for nothing? Now I don’t know if the drive is actually faulty or not.
  4. The cloud system is a little wonky (as are other things on this device). Could access was active and I had to deactivate then reactivate to be able to invite someone. And I no longer have a button to create a new account for cloud access.
  5. For local network users, I created new users and the share access options are completely greyed out. I can’t make any adjustments even though my share profiles are all established. This is the case even for the admin account.

One step forward…several steps back.

On the potential faulty drive issue, run a drive test in the My Cloud Dashboard to see what, if any, errors it finds. Also its possible the My Cloud polled the drive’s SMART data and it tripped an error on the drive. Could be that SMART test hasn’t been run yet due to the reset.

If the option to set user permissions for Shares is grayed out on the User page, double check the Share itself to set it to Private not Public. I think the reset changes all Shares to Public which means one has to go back through and select which ones to set back to Private.