EX2 changed internal IP address, now Cloud Access doesn't work

I’ll preface this by saying I am new to NAS and networking so any offered solutions may need to be detailed. And your help is greatly appreciated.

Prior to the other day, my EX2 was working just fine. I had it setup. Cloud access turned on. I could access it from both my IOS devices via the My Cloud App as well as on my Windows computer via the My Cloud Desktop program as well as mycloud.com from any computer with no problems.

Then – just the other day – Everything stopped working. IOS, Windows desktop, and mycloud.com all stopped. After a few diagnoses items, I realized that the dashboard was trying to connect to a different internal IP address then what was showing on my network. It appears it automatically changed from 192.168.0.2 to 192.168.0.3. Once I redirected the shortcuts on my desktop to point to 0.3 I was able to connect to the dashboard perfectly. Once I realized it was pointing to 3 and not 2, I changed that and reconnected to 0.3 on the My Cloud Desktop program and reconfigured and reconnected the IOS Apps and both seem to work. However, I cannot connect when I go to www.mycloud.com. That is still not working.

Logging into the dashboard and going Settings>General>Cloud Access, the connection status reads Failed. That must be why I cannot connect to www.mycloud.com . So , I tired turning the service off, then on, and click configure, its set to Connectivity=Auto (I am not sure how to setup manually). I clicked on Rebuild Content Database to see if that would solve it. No joy.

No matter what I do, I cant seem to get the Connection Status under Settings>General>Cloud Access to succeed. Any help would be greatly appreciated.

Hello, some pointers:

  • Set up an static IP address on the WD My Cloud.
  • Check if ports 80 and 443 are open, if they are not open you will need to contact your ISP for them to open it.
  • Create a port forwarding rule in your router to point to the IP address that you selected for the My Cloud, might need to contact the router manufacturer or if the ISP provided the router, you will need to contact hem.

Thanks for the reply, lluna. Looks like TIME and waiting has solved my issue. I am now able to access everything via cloud access without changing anything.

You did provide me with useful information so thank you. I may go ahead and setup a static IP as you suggested. As I new to networking and NAS systems, please pardon my ignorance, but if I do go ahead and setup a static IP and Port Forward those ports, how will other devices on the same network behave that require use of those same ports? Example, I have my PS3 on this same network and it has been also describe to me to setup a static IP for the PS3 and port forward those same two port numbers, so my question is - how can you port forward the same ports to different static IPs? Does that cause issues?