Ethernet port dead, yellow flashing light on the front

My 3TB My Cloud has no lights on the ethernet / network port. So I’m getting a yellow flashing light on the front. Tried different patch leads. The socket has no activity lights what so ever.

Any ideas?

I would try unpluging the cable from the mycloud and plugging it into your PC, and the cable from the PC an plugging it into the mycloud. if the issue moves it is a cable and/or router issue. if it stays at the mycloud contact WD as it is a bad port

Tried connecting to the router, switch & laptop RJ45’s. Cat5 & Cat6. The units port is still without lights.

sounds like the port then

you can try unpluging the power for a minute and pluging it back in, doubt if it will help but can’t hurt at this point

Already tried unplugging it & a soft reset. I’m about to bust open the case & see if somethings loose.

if it is still in warrentee WD should replace it but probably not if you open it

The problem is that I need to access the files.
Nothing looks out of place inside the case. Did a hard reset & still nothing.

I think it’s all down to the $2 ethernet socket module.

Same problem here on a two week old EX2 :frowning:

Very disappointing

If you have a Linux system you should be able to pull the drive an mount it, I doubt if there is any way to mount it on a Windows system.

I doubt if WD would copy the files to a new mycould as a warrentee exchange but you could ask

might be worth looking in the connector, make sure all the wires are straight and parael

See the User Manual, P.10, LED’s.  Do you have Quickview, if you do check and see what it says about the Temperature?

Posted by,
cat0w (USA)

sorry but if the network connection is down this is not possiable

the only way i can see to eliminate this possiability is to unplug it for at least 1 hour so it can cool down. then try again