Ethernet not working - out of the box

48-port Gigabit ethernet switch SLM2048

Lots of IP-enabled kit round the house

Cat6 cable everywhere

Brand new self-built house

Home network working like a dream

Already got 1 WDTV Live Hub working happily away in the basement - this one shipped perhaps 9-12 months ago (to the UK) and came with a slide on power adapter (US market?).

My second WDTVLH arrived today, this time with a push-in and screw-tight adapter (Asian market?),

I unwrapped it, connected it via HDMI to the Panasonic TV, exactly like the one in the basement is connected and to the same model and year of TV.

100% working ethernet cable connected to 100% working ethernet port on wall connected to WDTVLH ethernet port.

“I’ll just be ten minutes darling, whilst I start all the firmware updates…”

That was 4 hours ago. :angry:

So I tried automatically finding IP address. Nope.

Then I tried manual settings, based on the settings from downstairs (but obviously changed static IP address to something not already in use on network). Nope.

Reboot WDTVLH. Tried both steps again. Nope.

Reset to factory settings and then reboot and then tried both steps again. Nope.


Roll back firmware to 2.07.17 (? i think) from 3.0.something (? or similar)  and then try all of the above again. Nope.


(By the way, each time I try one of these things I notice that when I check the ‘connection’ via the menu, it fails - 3 red crosses - and when I go to check the ‘system’ via the menu I can see the MAC address but the IP, Mask, Gateway, and DNS all read

Double check all ports in lounge - all good. Check cable - also good.

Turned WDTVLH around so I can see ethernet port light as I fiddle with its settings.


Just an orange light, that blinks at random intervals between 2 and 15 or so seconds, typically with intervals of between 4 and 8 seconds.

I think my ethernet port on my WDTVLH is broken.

Any ideas?

I agree with you, the Ethernet port seems to be broken, you may take the Hub back to the place of purchase.

1 Like

Cheers Vadir, that is exactly what I plan to do. Only problem is that it was from Pixmania, and their returns warehouse is in France. So the chances of me getting a working WDTVLH anytime soon is remote. I think this might take a minimum of 2 weeks to fix.

They also won’t like the fact that I rolled back the firmware, but then again I doubt they’ll even realise. :wink:

Anyway, UPS will collect the faulty unit sometime tomorrow. I’ll post here what happens to my return and how long it takes. Thanks for replying.

So I contacted Pixmania and they arranged UPS to collect my WDTV Live Hub because it is over €100 and thus valuable.

They sent it back to their warehouse in France, and after checking it they agreed the port was faulty and sent me a replacement.

Which arrived yesterday, but I was busy.

I just plugged it in and guess what? Same problem.

This time it’s going back and staying back. Bad batch I reckon, so I’ll get one from another supplier.

Ok, back to the basics…  Have you confirmed that the cabling is fully functional for gig?

Have you tried plugging your Hub directly into your switch using a known-good patch cable, thus ruling out any possible issues with the in-wall cabling?

Remember that GIG-E requires all four pair to be fully functional…  one broken or shorted wire of the 8 will kill the cable.

Tony, hi, I made, and tested with a cable tester, the cable myself using Cat6 cable and terminators. Just for good measure I also swapped a known-working cable in. Also for good measure I did the same but used a different known-working port.

The wall plate also uses Cat6 keystones.

Anyway, Pixmania have just today given me a full refund for the 2nd device. I’ll get one from Amazon and see if their batch is a different one.

I’ll let you know how I get on.

Thanks for the reply.

Well, I am officially bamboozled. My Amazon order arrived today. Same issue. It has to be me. Any ideas on how to test this?

I already went downstairs and swapped the two WDTV boxes over at a known working port, and no joy.


Despite the two ports behind the TV appearing to work OK (by OK, I mean you could plug in an ethernet cable and you could get the internet on a laptop) I decided to do a little more investigation.

I made a very long cable so that I could test the WDTVLH using other ports around the living room. It worked first time with a different port.

Intrigued, I unscrewed the wall plate. To my absolute astonishment, one of the ports had the blue wire disconnected, and one of them had the brown wire disconnected. Yet they still worked for internet, just not for the WDTVLH. So when I thought I was testing with known-good cables, I kind of wasn’t…:cry:

A quick re-punchdown later, and hey presto! Everything working fine and dandy.

What a tool I am.

Thank you to all who listened and tried to help. How stupid do I feel now?

hi i have a qestion

can i use my WD live player in more than one network ??

like ip addess for pc

WD player

both are diffrent network

im using cisco router

wired conction

any heelp plzzzz  :cry::cry::cry:

I can’t believe you didnt test it directly to your switch with a fly lead.  Ohh well lesson learned.

check in your switch or router (if possible ) if you see the MAC address if you can see it its a software / driver issue

if you dont then its absolutely and undeniliably a hardware issue . ( from the looks of it its a hardware issue)

if all the cabling is validated with another device including the patch cable i would return the box .