Errors installing WD Black Dual Drive

So I bought a dual drive for my wifes Vaio Laptop (VGN-NS150D)… it’s a bit older, but not too bad. When I start it up, it sees the 120GB Partition as it should… but when I try to format the partition to install windows it pitches errors at me. One is 0x8007045D which is an I/O Error as near as I could find out. Below are the troubleshooting steps I took:

  1. Installed on another PC and formatted - Worked

  2. Installed back in VAIO and tried installing to formatted partition - Copied about 2GB of files, then pitched an IO Error Again

  3. Tried to partiion the drive in the laptop with a Linux Live (gparted) - Pitched an IO Error

  4. Updated the BIOS on the VAIO - No Dice

  5. Updated the Firmware on the WD Black - No Dice

  6. TRIED looking for ICH9M Sata Drivers for the F6 portion of Windows install - No Dice

SO I’m TOTALLY at a loss here. I’m thinking it’s a SATA controller incompatibilitly. 

Any help would be great. Thanks

Hello ssign. Check in the BIOS and make sure that the controller is set to AHCI or possibly IDE mode, as long as it isn’t set to a RAID mode. Do you have another drive that works in the computer? This would help to rule out any issues with the controller or cable. Are you installing with a Recovery CD? If so, it may not work and you may need to use an actual Windows install CD. A lot of recovery CD’s look for a specific capacity drive and pre-set partitions where it it sets up the recovery.

Yeah, there’s no options for RAID/AHCI/IDE in the BIOS. It’s really basic.
I’m replacing a currently functioning drive in the PC. I put the other one back in and it’s working fine.
And yep, I’m using a fresh iso from the msdn site.

1 Like