Error when changing e-mail

There are a lot of threads on the topic of changing e-mail adress. I’ve looked at most of them and i am sure that i am doing it right.
However, i keep getting an error when changing my email adress:

“This email account cannot be deleted. Make sure your device is registered and your network connection is functioning properly, and then try again. (250010)”

The funny thing is i can change the e-mail adress to an alternative adress i have (a gmail adress i use for registering on various sites) but i cannot change it to my primary gmail adress. Could it be an issue with how many characters there are before the

I.m on a Gen 1 MyCloud (latest firmware v04.05.00-327)

I would apreciate any help.

Ok i figured it out, so here is my solution in case somebody has the same issue:

Apparently i had cloud acces from my android device, which is registered with the same adress i was trying to change my mycloud to. This somehow prevented me from changing the email adress.

This is what i did:

In MyCloud dashboard:
So if you try to change your e-mail in the “users” pane (1) and get an error message when trying to change the email adress (2) like i did, go to the “cloud access” pane (3) and check if a device is registered with the same e-mail adress (4). If you have an android device with the same adress, click the trash can (5) (you can add cloud access later). The e-mail adress in no.6 should match the e-mail in no. 2. You can change the email adress in no.6 by clicking on the notepad after the adress. Change the email to your desired new email adress and BINGO! it changes the adress automaticly in no. 2!!
After successfully changing the email you can add the old android device back by signing out on your device and signing in with your new e-mail adress (see below).

Once you’re done, an email will be sent to your new e-mail adress, follow the link to create a new password and you’re good to go.

Now to add your android device back (you should be on the same network): Open the app on the phone and you should be prompted to log in with your new email. Doing this will result in a “no access” message, click on the “add device” just below “sign in” and you should be able to log in using username and password (this password is set up in dashboard and may differ from the password you use for acces with e-mail).

Once you have mobile access, close the app and disable WiFi on your phone. Now try to open app again (it will access MyCloud via mobile data) and you will be prompted for email and password, put in the new email and password and you now have access.
Remember to turn WiFi back on on your phone!

@Damon I take it this way did not work for you in changing your email address. From the Dashboard under User you select your old address and delete it then insert your new address and click on Save. See image below. This is the way I have changed mine when I needed to.

@cat0w No it did not work. It created the error message.