ERROR. Harddrive detected, but cannot access

I bought WESTERN DIGITAL My Passport Essential 2TB USB 3.0 [WDBY8L0020BBK-PESN] - Black in June 2013 for backup purposes.

Since then I only connect the drive once every month for backup my data. Just now, I plug it into my laptop, the safe remove shows the drive but windows explorer take very very long time when i click the drive and still cannot access the drive.

I heard, the motor is running fine. and there is a sound the head is trying to access the drive for couple seconds then it silent, after a while, the head trying to access the drive again and so on.

Practically I only plug it in for 8 times NOW and each about half to one hour backing up my data.

But now it is useless, I can no access my personal video data! All of it is gone. I have tried recovery software, none works!

Sure I can RMA, but what about my data?

Is the WD drive NOT RELIABLE for back ups? WD should say this!

WD claim tobe number one backups safe drive is lie!

FYI, The cable is good, I have tried it into my transcend usb3.0 drive and works fine.

Sorry to hear you cannot access your files. You can verify if the Passport has any hardware damage by running a test with DLG. If you are unable to recover your files with a data recovery program, there are some recommended data recovery companies on the WD support page that you might want to contact. Check the link below for more information.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

Data Recovery Partners

Sorry about your problem. You said this was a backup but moving files from the computer to another drive is not a backup. A backup is 2 copies in different places. Does the drive show in Disk management?


Mr Joe,

Yes it is backup.

I backup my files by copying manually each folder every time I need to backup.

And yes, i have 2 copies for each files. 1 in my laptop and anoher in my wd passport. Well not all in my laptop, mostly when my laptop’s internal drive is full, I delete some files knowing that I have secure backup.

The problem is, when last end of ther year, my laptop got hit by some virus, it wipes some of my crucial data.

After formating and restoring my windows system, believing that I HAVE BACKUP,

When I want to restore some of my works back into my laptop, the drive takes very very long time to show in my safety remove icon.

After it showed in my safety remove icon, the drive name is gone. I label the drive as “VIDEO”. The label is gone.

When I open my windows explorer, and click my computer, it takes very long time for win explorer to show the drives that is in my laptop.

When I try to safely remove, it cannot and takes very long time just to show t cannot be removed. I shutdown, take out the drive, then windows becomes normal again, win explorer is normal to access all my other drives interna; and external.

Once I plug in that drive, again, it takes very long time just tobe recognised by safety removed icon.

Yes after a long time to be shown in my safety removed icon, I can see the drive in disk management being empty.

Of course, when i open my computer management, it shows the drive healthy with free space 1862.98GB without label.


On the middle is icare data recovery program. It shows E: is labelled “VIDEO” but the label and size doesnot showed in win explorer.

When I recover with icare data recovery, it took 3 days to finish searching, and I dont quite remember was it 2 or  more days to copy the recovery data to another drive, and I can see the drive’s label “VIDEO” and their folders but the data that was recovered succesfully according to icare, are all error. Not even one avi file can be played back.

I have tried another data recovery programs, all data recovered are all error.

The motor si winding normal, I can hear the head reading sound, trying to read then stop, then after a while try to read again, until it shows in my safety removed icon.

So, backup using WD passport  drive is useless, UNRELIABLE.

Probably not all person buying passport have the same problem as I am, but still, it shows to me an unreliable drive, for a drive that I specially used only for backup.

Thank you for your response.

Mr Ichigo,

This is my screen capture that i captured two days ago when I try to repeat the data recovery process, hoping i can save the data!


As you can see on the right is my win explorer after very long time i shows H:\ without any label, without free space or total size. Please note all other internal drives have total size.

On the middle is the icare data recovery program, the H:\ drive has label “video” and shows total size!

and left is DLG tools. I dont understand the numbers showed, but for instance “raw read rror rate” worst is 126, the value is way above worst, 131 etc.

Also in DLG tools, you can see the H drive doesnot have any total size and file system! but the icare shows ntfs and its total size.

What is wrong with this rare plugged-in wd passport?

Sure I can use data recovery partner but how much do i have to pay because of this unreliable wd passport?

It will not be cheap, right? Will WD pays for the recovery? I guess NOT.

The videos I backed up are all my family video. I can not repeat the video recording again! It is our only memory of life.

It is not any common video that I can download everywhere on the internet. That is why I only use this one as backup drive.

Thank you for your response.

Don’t know why, the screen capture was there yesterday, and this morning (my time), I wanted to reply for mr Joe, I notice it is missing. So I put it back again.

Have you tried accessing the drive by booting from a Linux Live CD? Sometimes that allows access to data. 


Mr Joe,

I have not try that. I will try later after unsuccesfull recovery.

Right now I still trying to recover using icare data recovery again just to see if the data recovered can be read fine this time. Last time, although the data can be recovered according to icare but when I try to play the avi, they are all error.

I use icare again because it is the only program that can show the drive’s label “VIDEO”.other recovery program, either takes longer than icare (25% reading the drive in more than 2 days), or only found some data in it (not all avi).

I’ll give it another try. It has been 2 days now since I started icare for the second time. Just now I see, it has search 50% and found more than167.000 files.

All of video files I have since 2010 are in this backup drive! 90% are dv avi and avchd mts format. Some are raw and jpg’s from my Canon camera.

Thank You.

Having this exact same problem, no results.