Email/user login field greyed out, can't log into mycloud

I have a very old MyCloud, and want to reset to factory settings before I dispose of it. However, although it’s showing up on my windows network, and I can get to the files ok, when I try to log in to delete users/wipe the drive etc, the email field is greyed out and none of my passwords work. I tried to log into my account on the mycloud site, and it says I don’t have a western digital account, then that I do, and password is wrong - click on ‘forgot password’ and the link to that page is broken, so I’m stuck. Can anyone help out? I’m afraid I can’t give any more details, as I can’t access the settings/control panel at all, and I’m not that tech savvy.
Sorry if this post is in the wrong place - it’s my first try!

Do you have a My Cloud Home or My Cloud? They are not the same. If you have a My Cloud device, what specific My Cloud model do you have? Can you access the My Cloud Dashboard? If so what firmware version is it showing? If one can access the Dashboard one can perform Full Restore which will erase all user data and reset the My Cloud to factory defaults.

My Cloud OS 5: How To Access the AdminUI Dashboard

My Cloud OS 3: Access the Dashboard

Thanks for the links - the first one worked, and I’ve finally been able to get to the dashboard and do a full restore :slight_smile: I was trying to log in in the wrong place - thanks for helping out!


What is showing under Network for your devices? (Storage) See example images below. WDMYCLOUD is my 1st generation OS3 device. WDMyCloudTwo is my 2nd generation OS5 device. A right click on them and then a click on, View device webpage should open the Dashboard.

Thank you - I’ll remember to do that next time. It’s so long ago i accessed it I think I got a bit fuddled!