Email share


using the wd mycloud desktop app I can open the directory structure on my drive when i right click and select email on a file my browser opens on the google home page it does not go to my email which is gmail 

This in on windows 8 on my smartphone if i do the same it opens gmail with the link embedded in a message ready to send which is great how can i get this to work on my desktop



Your browser has to be set to Gmail as its default email client or how to handle email links.  Google up the settings for it. 

thanks I have gmail set as default email in firefox but still only get a new firefox tab opening when i right click and select email in wdcloud desktop app

other people must have this working any help please


Tnynyn is correct — you need to set the WINDOWS email handler.