Elements Desktop not found in media library


#1

Hi,

I have just recieved my WD TV Live box and as soon as I had the device in my hands I plugged it into my TV and logged it on to the internet - no problems there!

It did automatically update the firmware to the newest version and wupti, ready to enjoy all my great movies from my external USB-drive. But when I plug the USB into the device (I have tried both USB-ports), nothings seems to happen. I have tested with a USB-stick/pin and it worked fine with no problems.

I have a WD Elements Desktop 1.5 TB disc (ntfs formatted) which works great on both PC and mac.

How come?

Thanks

Kasper


#2

In addition to my thread: I have read that the external drive I am using is indeed supported by WD TV Live. That is written here: http://community.wdc.com/t5/General-Discussions/Elements-Desktop-not-found-in-media-library/td-p/17832fa


#3

 You could try the following, it sometimes helps. (however other people have had problems with their hard disks after this update)

reset to factory defaults in the internal menu.

reset the unit using the side button (a quick press with a paperclip with the unit on)

Disconnected the unit from the power adaptor and left it without any power for a few minutes. (not seconds)

Remove the hard disc before doing any of this.


#4

If this trick doesn’t work please take a look at this threat and chime in. We need WD to address this problem that makes our WD drives pretty useless.

http://community.wdc.com/t5/General-Discussions/HDD-only-recognized-after-reset/td-p/18079