DX4000 on UPS

I have my DX4000 plugged in to a Tripp-Lite intelligent UPS.   So far all I can get is an ungraceful shutdown when the battery reaches a certain level.   Then many hours of “verification”.   Does anyone know how to get this to work correctly.   The vendor software requires JAVA which doesn’t work on the DX4000.

You can instal Java.  On your pc clcik start and type mstsc and enter.  Enter the name of your box and connect.   Administrator and the password you gave it during setup.  Open IE and install java

Tried installing JAVA once which failed.   I’ll try again.

Is it really even necessary to install the Tripp lite software. Im going to buy the DX4000, but just learning about it right now. I have used UPSs from APC and Cyberpower on Windows 7. It is unnecessary to install the software from APC and Cyberpower unless you just want extra bells and whistles. Windows 7 has built in power management that will do a graceful shutdown. I would assume Windows Storage Server 2008 would have a similar power management feature built in.

Yes, from my very painful experience, Stealle is correct.

I purchased a cyberpower PR750LCD and connected it to the NAS via usb cable.  Then go into your windows 7 accessories directory under the start button and click on RDC (remote desktop connection).  You will need your admin password and then just sign in.  This will take you to the “desktop” of the NAS OS.  Look for the laptop-style battery icon in the lower right corner (the system tray).  If you see it, your ups is compatible and connected properly. Then click on the start button and select control panel.  Type “ups” in the search field and select power options.  From there select a power plan and then “change plan settings” (you might also have to click on “change advanced settings”).  Scroll to the bottom of the list and you will see something along the lines of battery settings.  Click the “+” box and the key adjustments will be available.  I changed the low power and critical battery settings to “shutdown” with about 20-25% battery left.

I haven’t had a power failure yet as I just did this today, but I’m optimistic that this will do what needs to be done without installing the ups vendor software.

PS - I purchased a cyberpower ups about a month ago that literally just died about a week ago…not sure why I bought a new one except I did upgrade, so I purchased a 2nd power brick from WD and will plug it into an older UPS I have just laying around as a back-up.  Don’t want to go through the reinitialization process again, ever…

I’m am by no means an expert here, but if you have questions on what I did, you can e-mail me and I’ll try to help (vacanthomes at comcast dot net) - not sure I will be checking this forum too often.

Good luck. 

I’ve got an APC UPS attached to my server.   I have not installed any additional software.   The server sees that it is there and gives battery level inidication etc if the power fails.

This morning I thought I should test the auto-shutdown in case of power failure.   I changed the Critical Battery Level to 80% in the power plan at which point it is should Shutdown.   I then pulled the power to the UPS.    The server kept running as expected but when the power level hit 80% it simply powered off, ie it did not shutdown.   I powered the server back up again and it booted OK but it is now verifying … 20% completed after just over 2 hours so it is going to be a 10 hour process.

I don’t really kinow what else I can do to avoid this.   The UPS will protect against power outages of about 90 minutes which is good but I really want it to shutdown properly when the critical battery level is reached.   All the settings appear to be correct so I don’t know where to go from here.

Not sure I googled a bit and some suggest you need software.  Here is a link that suggest shutdown does not work, and the workaround is to select hibernate?  Also has a link for more reading


Anything new here?  Has anyone had a power failure after properly connecting a smart ups?  Did you get a graceful shutdown or not?  I thought my setup was perfect until I read the above posts…argh!!