DVD menus do not work on some DVDs ripped using AnyDVD


I bought a WD Live TV Hub primarily with the idea that I would store my DVDs on it for convenient access. Most DVDs work fine, but for some DVDs I have encountered a problem which has been mentioned in these forums before. For some DVDs, rather than getting a DVD menu, I get a blank screen. I can still watch the DVD from the gallery preview, but without a DVD menu. This is very frustrating for TV shows as I cannot chose an episode.

I use AnyDVD to mount my DVDs in an unencrypted state, then I simply copy the VIDEO_TS to the WD Live TV’s hard disk. The problem occurs with many DVDs, such as a Season 1 Seinfeld DVD; it works perfectly for other DVDs. I have not identified a pattern.

Some of the forum posts indicate that the blank screen bug is a firmware issue, but it isn’t clear whether this problem has been addressed in the latest firmware (I am using Firmware 3.06.14). Some posts indicate that rolling back the firmware to an earlier version might resolve the problem, but I have not tried that (as it seems like a poor workaround). Other posts have indicated that this problem can be caused by the ripping software messing with the menus chains. I have tried disabling all the features in AnyDVD which promise to “removing annoying menus,” to no avail. I have also tried generating an iso of my DVD (also using AnyDVD for the decryption), rather than copying the VIDEO_TS, and this still does not help (although if AnyDVD was causing the problem, I can see why making an iso would not change things).

In all cases, VLC Media Player on my PC is able to view the DVD Menu’s with no problems, so I suspect the firmware on the WD Live Hub is being rather finicky when it comes to interpreting certain DVD menus.

A few questions that I would like answered:

  1. Does the current WD Live TV Hub have any known issues with DVD menus? If so, is a resolution forthcoming?

  2. Is there any ripping program which is known to always produce good copies of DVDs, so I can test whether AnyDVD is causing the problem with the menus?

  3. Does anyone have any specific experiences with using AnyDVD with the WD Live TV Hub and with DVD menus?

  4. Is there any sort of diagnostics I could send to WD support to help them address this issue?

  5. Could I use a DVD menu editor to attempt to fix this problem? If so, are they any tutorials I can use? My experience so far with DVD menu editors is that they are incomprehensible to mere mortals! :slight_smile:

Thank you in advance for any help you can offer me!

– Marcio

Most likely it’s due to a form of copy protection used in the authoring of the DVD (Encryption is the oldest form; there’s many newer forms that you’re NOT getting past by just copying the VIDEO_TS folder as-is.)

It’s a form of copy protection, and by just copying the unencrypted VOB & IFO files, you’re copying that form of copy protection, too.

There’s MANY DVDs that have such shemes authored into them.