DVD Fab m2ts and MakeMKV files ok but encoded Handbrake mkv freezes!

Hi everyone,

I am new to the ripping/encoding thing. But, have managed to rip Thor bluray successfully using DVD fab to an m2ts file. From what I’ve read so far I could do that and shrink that 29G file down to something a lot smaller using Handbrake. So I took my m2ts file (which plays fine on my WDTVLiveHub fine), ran it through the HB high profile setting pretty much leaving most if not all in the default settings and shrank to a 6+Gb mkv. It starts, then freezes at the Paramount intro. I tried the same thing using MakeMKV to a 29G mkv (which also plays fine), then used HB again…same result.

I’ve tried searching the forum and others to find an answer but haven’t found anything that seems to mirror my particular situation. I’m sure it’s probably been discussed. So, if anyone found point me in the right direction it would be greatly appreciated. Thx.

See this post HERE.

1 Like

Thanks for the quick reply! I actually did see that post this morning and was wondering if that would work for me. I will give that a shot when I get home tonight and let you know if it does the trick. Thanks again!

One quick observation…in the discussion you sent me a link to, you mentioned “the same files would play flawlessly on my HUB…”. I’m assuming you’re saying that even though my problem is on my HUB, I should still run my mkv through MKVtoolknix because there still may be an issue with the “libmkv 0.6.5” writing library?

And near the end where you say “…unlike the hours it will take you to RE-ENCODE w/ Handbrake”. Are you saying after MKVmerge, I have to run it through HB again? Seems to me, I would be done after the MKVmerge step…sorry, guess that was “two” observations :stuck_out_tongue:

The issue is on the HUB also, what I was refering to is that mkv’s with the “libmkv 0.6.5” will play on the HUB with firmware version 2.07 (I should have been more clear about that) which is what I have stayed on because of the bugs in the later versions.  The same issue for the SMP has been found on the later versions of the HUB firmware.

And no, you don’t have to encode with HB again.  Just take the HB mkv’s that you already have and run them through MKVmerge.  That will change the writing library from “libmkv 0.6.5” to “libebml v1.2.3 + libmatroska v1.3.0” writing library that MKVmerge uses and then you should be able to play the file.

Now, if you haven’t encoded your movie yet you will always want to use HB first, because MKVmerge is a 1:1 encoder not a transcoder.  But after you have encoded with HB, then you will have to run them through MKVmerge to fix the writing library so the HUB / SMP will play them.

1 Like

Thanks for the clarification. I will do this tonight as soon as i get into “me time” :).

Looks like I may have to revert to Firmware 2.07…if I can? As I mentioned, I’m new at this and thought it made sense to update my firmware whenever a new one was available. I did run across some discussion on firmware versions in my previous research but wasn’t sure if I was going to need to doing something myself. I will look into that as I’m sure if that is a possibility it’s probably here somewhere as well. Of course if you have a link for that too it would be greatly appreciated! :).

Here you go:


1 Like

You’re awesome! Thanks much! I will let you know how it goes.

running through mkvmerge worked great!..even without reverting back to version 2.07 of the HUB firmware.  thanks again!  i guess the resulting question is…if i revert back to the previous firmware, will that alleviate the extra step of having to run through mkvmerge?  as i’m sure you are well aware, every bit of time saved is huge when having to build up your library.

also, which do you think yields better quality?: dvdfab to m2ts, then mkv w/ handbrake…or makemkv to mkv, then handbrake?

If you do roll back, then you will not have to preform the extra step.

As far as quaility, just rip with dvdfab (DVD9 or BD50), then encode with HB.

Great!  Thanks again for all your help.  Very much appreciated!

First, in trying to roll back to firmware 2.07, I’m wondering why i’m not getting the “New Firmware” option?

Second, “DVD9 or BD50”?  I see that dvdfab “blu-ray copy” (which i only have the trial version of) has the BD50 output option.  But dvdfab “blu-ray ripper” doesn’t.  I used the trial version and output to BD50.  i was expecting to get a 50G or so file but only ended up with a 26G file in the “STREAM” folder.  Furthermore, when i choose this source file in HB, it shows that it is a m2ts file (which is an option i have in my registered “blu-ray ripper”).  so my question is: is the BD50 file from blu-ray copy the same as m2ts file from blu-ray ripper?  they are roughly the same size file.  am i correct in assuming the BD50 file should be much larger and what file extension should it have?

Well, if you’re not seeing New Firmware, make sure that you have the HUB set to auto detect firmware.  If you still don’t see it, try unplugging the power cord then plugging it back in.  If you still don’t see it after that, go to Setup / System / Device Reset.  This will reset your HUB back to factory defaults and then you should be able to see the “New Firmware” and then you can rollback.

The BD50 only means that you can burn to a BD50 disc, not that the file size will be 50GB.  All that setting is for is so that you don’t get a compressed output.  DVDFab has 2 options, BD25 (for 25GB disc) and BD50 (for 50GB disc).   If you select BD25 and you movie is larger than that, then dvdfab will compress it to fit on that size disc.  With BD50 it doesn’t compress the file so what ever size your movie is, is what the output will be.

Also, in HB you don’t want to select the m2ts file (don’t use Source/Video file) if your movie is in folder format on you HDD.  You want to select Source/Folder, because some BD’s have multiple m2ts files that make up the entire movie, although the most are a single m2ts file.

So if say you have ripped Iron Man, with HB you don’t want to select Source, then select Video File, then go into the Stream folder and select the m2ts file.  What you want to do is to select Source, then select Folder, then select the Iron Man folder and then click on Select Folder.

Tinwarble wrote:

Well, if you’re not seeing New Firmware, make sure that you have the HUB set to auto detect firmware.  If you still don’t see it, try unplugging the power cord then plugging it back in.  If you still don’t see it after that, go to Setup / System / Device Reset.  This will reset your HUB back to factory defaults and then you should be able to see the “New Firmware” and then you can rollback.


If he isn’t using a proper “rollback” file set he MIGHT need to edit the .ver file??? Just thinking about what else it COULD be…

I Know it sounds silly …

Has anyone suggested checking the “Auto Detect New Firmware” is “ON”  ?

Setup > System > Auto Detect New Firmware 

Yes, I did check that the hub was set to autodetect new firmware.  One thing I didn’t mention was that a new firmware was actually available when I went through this process.  Apparently, it updated to the latest version.  I then went through the routine again and never got the “new firmware” option again.  I did the reset and the autodetect was on.  I’m going to check my thumbdrive to make sure the rollback files were in the root directory, but I’m pretty sure they were.

As to the BD50, what I am trying to avoid is spending another $60 on the Blu-Ray Copy component of DVDFab.  I purchased the DVD Ripper and Blu-Ray Ripper components which, as I mentioned, seem to only give me the option to rip to a single mts/.m2ts “file” and not BD50 and it’s associated folder structure…although the resulting Ripper file is pretty much the same size as my copy to HDD using the trial version of Blu-Ray Copy.  That makes me want to think that the Ripper file is also not compressed.  So, is my resulting m2ts from Ripper the same end product as the BD50 (showing as “.m2ts” on HB) produced using Copy?

Also, IF Ripper does output a single m2ts file without compression, is it safe to assume that it would rip both m2ts files found on a BD (as you mentioned this may sometimes be the case) and combine them into a single file…without compression?  Is this the only reason to choose a source folder rather than source file?  And, when you say “select the Iron Man folder”, should the target folder be the subfolder that the actual m2ts file(s) is/are in (i.e. the STREAM folder)?

In the end, I guess my question is when using Ripper, is the resulting m2ts compressed or not? (probably a question for the dvdfab forum)  And, if it is not and I thus choose to use Ripper, can I just select the source “file” (as Ripper does not output a folder structure but a single m2ts file).


Yes, I beleive that it was my first suggestion.

Quote: “Well, if you’re not seeing New Firmware, make sure that you have the HUB set to auto detect firmware.”

Not trying to be a smart ***, just sayin’.:wink:

Anyway, as suggested you do need to make sure that the .ver file in the firmware does show that it is a higher version than the current version.  It is already supposed to be changed for you, but since I don’t use those downloads I pointed you to I can’t confirm that they are.  So you need to open the “wdtvlivehub.ver” file with notepad and make sure that the “VERSION=” number is higher than 3.04.17, if not change it to a higher number and save.

As for the other suggestions I made.  I have had the exact thing happen to me once before and those suggestions should work for you the same as they did me if it’s not something else.  Actually, when it happened to me I thought it was because something had happened to my thumbdrive that I use to flash firmwares, that is until I tried 3 different one’s and couldn’t get “New Firmware” to come up.

Also, what I said about getting your movies to your HDD, that was just a suggestion.  If how you are doing it works for you then that’s all that matters.  My point though, was to make sure that you were using an uncompressed version of the original to encode in HB and make sure that you weren’t using a compressed version.

Sorry, meant to post as a solution a while ago.  But, you know how it is once you find the answer and start building up momentum ;).  Turns out my FW roll back file were NOT in the root directory.  Once I rolled back though, everything is working fine now!  Thanks again for all your help Tinwarble.  Started working with moviesheets and using your Mojo MSP (Great work!).  New issue now is why can’t I pulldown the “Mojo_Glass_Sheet” template in the Thumbgen when it worked the first time?  It’s only showing me the default TG template.  But, I will post that question on the appropriate thread.  Thanks again!