DS6100 Boot raid rebuild hung at 99%


#1

Hello everyone,
First off thank you for the info that I have already found here. Its been a time saver getting up to speed.

I am new here and recently picked up a DS6100 unit for my wife’s small home business. I know it was over kill but I am an IT guy and like toys plus the prices was good. I got the unit all configured and it was working great but we had a storm roll in and the power went out. needless to say when the DS6100 came back up the boot raid was not happy. Turns out one of the 320GB drives got wacked and needed replaced. However before replacing it I tried a raid rebuild on it and had my fingers crossed. The rebuild went to 99% and hung there for days, then finally I had some errors get reported in the monitor logs. Yep bad sectors found so the drive is shot. I even put the drive in another computer to scan and mess with and it all pointed to a bad drive. I ordered a new one same make and model. It arrived and of course it was a new drive so the unit didnt like it and I had to add it to the devicelist.xml file (Thank you to all that put time in to find this. Saved me some time.). Not a big issue at all. Rebooted to be safe and was happy to see the new drive was now marked in green and the raid rebuild started automatically. However…I am a few days in and hung at 99% again?!?

So what is the deal? Do I just need to wait it out again? I am use to working on big servers and have never had to wait days for a mirror set to be rebuilt. I also noticed that in this state the OS is VERY slow. Is this normal even thought resources are about idle. I will be installing PUTTY when I get time and connecting the the controller to take a look.


#2

Hi mitchrd2004,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.


#3

Just curious, what is PUTTY and what will it do?

Have you restarted the box?


#4

Gramps,
I have tried just about everything. In my 18 years plus of IT in a server environment I have never gone form impress to upset in such short order. 1. I cant believe that WD would fully restrict the drives by making a white list down to the exact model number. I can see limiting it to a family of supported drives but they had to know that if there was ANY change or revision to the hard drives that the new drives wouldn’t work without making additions to the file since the end of the part numbers would change. 2. Total lack of logs that show what the system is up to behind the scenes. So my rebuild is hanging at 99%, tell me exactly what the heck if going on and not a stupid bar on the screen or the lack luster monitor that never updates. Was it just taking 4 days plus to move to 100% or did it go belly up. I am not sure why rebuilding a 230GB drive would take more than a day. I am very disappointed and cant even think of rebuilding the 12TB storage side
I was planing on using PUTTY to telnet to the RAID controller to see what was going on but because of the lack of time I felt it best to wipe the unit and go back to out of the box settings. It wasn’t hard to configure and the EXTREME slowness I have been experiencing since I replaced the bad boot drive and started the rebuild is enough to drive anyone crazy. However when I tried the reset process I was presented an error as well. Lol I will get back to it soon. Just had a busy few days and then a day without power at the house. (I am sure that didnt help this unit. :frowning: )


#5

Looks like I have corruption on the boot drive that didnt fail from the power outage and need to get my hands on the Recovery ISO. I thought I went above and beyond when I made a copy of the Recovery Partition prior to having issues but after reloading and trying to boot up I get a 0xd9 error. I have tried removing either drive and booting but no luck. Next will be to do a format on the drive to make sure they are 100% clean on another PC and then stick one in the DS6100 and try to use my USB back up to restore.


#6

Keep us posted. As well as would like to see how you get to the raid controller with PUTTY


#7

Well I thought I was in better shape. I was able to load the image I made of the recovery partition and had my fingers crossed. After the first reboot it started loading and had the circle in the lower middle of the screen under the boot logo. It looked like it was loading drivers and took some time and had a % shown. Finally made it to a black windows with a mouse pointer and just sat there. Then the unit rebooted on its own and when it came up I had the Failed: 0xD9 error and after that I now has a SHELL window up on my screen.


#8

I forgot to mention. I pulled all the hard drives out of the device except for one of the original boot drives in A.


#9

I may have jumper the gun. At the shell windows I typed in exit, the unit rebooted again and came up with a GUI Windows Setup. CMD /c c:\wd\run_logged_install.bat c:\wd\wdinstall.bat with a CMD window kinda behind it. Displaying bla bla bla already exists. Then powershell windows are up and down so I think something is installing.


#10

Oh… the BIOS boot order needed adjusted. Oh the simple things. Lol Now I am sitting at a Blue window asking for my language. I think I am rocking now. Best part is that the fan speed is now low and it doesn’t sound like plans are in my office. :grin:


#11

I am going to take back some of my original complaints. The event logs are now working for Raid rebuilds and other issues. I am not sure who did what to this thing before I got my hands on it but it was in a sad state and I didnt know it.


#12

Things were going good with the boot drive raid rebuild. There were entries in the log file of the WD RAID Storage Utility and new entities every 10%. I headed out to cut grass when it was at 80%. I come back in ti see it at 99% and all the log file entries are gone. Very strange!

I have ran ZERO updates and disabled all windows update before starting the raid rebuild. I didnt even start the “initial configuration”. I wanted the raid rebuilt so I could run a backup before starting.


#13

What would make the logs go away? Still have drive issues?

Wondering if using a different drive than original it is hanging at 99 because the logic is hung somewhere?


#14

But why 99% with two different drives? After a few days the original drive did kick an error in the log with bad sectors being found. I just cant believe this second drive is at 99% too. The other thing is like you said, why did the logs flush? Now the software and OS is laggy. Just wish I could see what’s going on. I read that You can telnet to the controller with PUTTY but I have not had to to look into it more. I also read that the resources can be adjusted to process the raid rebuild faster.


#15

As of this morning it is still hung at 99% with zero entries in the log. I had my fingers crossed that there was a software issue and a fresh install would have cleared this up. I am open to ideas and don’t think that WD will be calling about the ticket I submitted.

The new build is on the fresh hard drive and the old hard drive was formatted and test on another PC and ran great under windows 10 for testing. Maybe I need to find some WD software to scan it with?


#16

I am starting to thing the WD raid software is hung or crashed. The entire system is sluggish but the resource usage looks fine.


#17

I think there must be another devices.xml type file somewhere that does not match your drive and it is in a loop
anything loggish in c:\wd


#18

After days of letting it run I finally canceled the rebuild and am able to read the Event Logs. 4611 events!! Lol “Command [0x28] oh physical disk port 0, boot drive 1 failed. Sense key=0x0, ASC=0x25380b97, ASCQ=0x1” I will dig around in the logs but that is the last error over and over. Just wish it was view able before canceling the raid rebuild.


#19

did it speed up after you cancelled? Mine only came with one oot drive so I thought I was being smart and ordered a black drive. When I opened it they used AV drives. Are you getting AV drives?


#20

It did speed up after I canceled but still shows some slowness from before I started the RAID rebuild after the re-image. The drive I ordered has the same part number as the one that went bad however the last set of numbers are different. Before the re-image I added the exact model number to the drive list and it was listed as green in that window.

After the re-image I went straight into the WD RAID software to start the rebuild. I did not make any changes since it was in that list. The device still says “Please Complete Initial Setup” on the LCD.