Dropped 1.5TB Elements, need help!

I have a WD Elements 1.5TB External.

It was my back up. I formated my main drive, taking a chance having only the back up for a few days… of course, while I was accessing it, I tripped over the cord and it dropped onto the floor.

I’m on a Mac OSX 10.6.8

The drive wouldn’t show up, but would eventually show an error, something like, can’t read drive and gave me the option to initialize, ignore or eject. It did this a few times and then the drive mounted but ran super slow.

I ran disk utility on it and the repair passed. I then started to copy files and it was going for a few minutes and then it stops and disappeared from my desktop.

The drive spins and sounds like it always did, normal drive sounds, no clicking that I can tell. 

Now all I can get it to do is give me the original error with three options (init, ignor, eject). However, when this happens, it shows up in disk utilty as WD 2.2TB Media but I can’t repair or do anything.

I took it out of the enclosure and used another USB hook up. I get the same error but this time, it shows up in disk utility as just “media” and can’t do anything to it, grayed out.

I tried freezing it for an hour, over night, nothing.

I can’t justify $1000+ to recover but I’d love to get some of the info back…

Ive sinced bought (2) 2tb WD Element drives… redundancy.


Well since it fell the disk may be physically damaged. If that’s the case there is nothing you can do.