Drive shows up empty... but it's not!

hi there,

While I was copying some files on the drive, my 2-week old 5TB drive slipped from my desk and got disconnected. As this happened before with other drives I didn’t make much of it until I reconnected it. It struggled to mount but I managed to do it via Disk Utility.

Disk Utility fails if I click on repair.

I tried the drive on another Mac and it appears with a padlock.

But the odd thing is that Catalina stops working while the driver is plugged in; the finder crashes, WD support tools don’t open, etc. When I unplug it, everything magically starts working again; the drive even shows up on the desktop (twice) with no help and shows the folder structure (but still no files).

If I run diskutil list on the terminal, the drive appears FIVE to SEVEN times.

I downloaded and paid for Disk Drill, which also struggles to run a bit (it’s currently saying that it will take 14 hours to finish its process).

It starts spinning and doesn’t make any weird noises.

Any thoughts?

Thank you in advance.

MacBook Pro (15-inch, 2018)
Processor 2.6 GHz 6-Core Intel Core i7
Memory 16 GB 2400 MHz DDR4

Get a new desk where things can’t slip off it … you were lucky with the other hard drives slipping and working afterwards, but sounds like your luck has finally run out.

https://support.wdc.com/warranty/datarecovery.aspx?lang=en