Drive letter and data missing on My Cloud

Just sat up my 2TB Book Live and configured it with WD Smart Ware. In the Windows Explorer it showed:

  • TimeMachineBackup (\ (V:)
  • SmartWare (\ (W:)
  • Public (\ (Z:)
  • …and (My name) (\ (X:)

I have several hundred GB of data on my WD Elements that I need to transfer to the Book Live. Doing a simple drag and drop from Elements to Book Live was taking an eternity. I followed the steps from another community post by turning on SSH in the Cloud Dashboard. Connected my PC directly to the router w/LAN cable and turning off the WiFi)

The above mentioned drives V, W, Z and X showed up in Windows Explorer. When I connected the WD Elements the Book Live drives got disconnected with a Red X

Tried to “Map Network Drive” and all that happened was that (My name) (\ (X:) no longer was to be found. Got a loner "Warning:…(X:) no longer can access that drive [or something to that effect] "… I already had several GB of photos on that drive and can’t find them anymore.

Restarted my PC, turned off the SSH and connected to the WiFi again. Only the V, W and Z drive are showing :worried:

I’m running Windows 7, 64 bit and WD Book Live with OS3

Any good advice?

I want to mention that the (My name) (X:) folder shows up on WD Dashboard and WD My Cloud - but still not in Windows Explorer

Have you looked at the WD My Cloud User Manual? See Appendix C P.92.


Followed the instructions in the Appendix. Clicking Map Network Drive. I get “Windows cannot access…
Is there maybe one more way? I really don’t want to reset My Cloud as the back up of my PC alone will take over 24 hours.