Drive LED not blue, but not red either?

Hello all,

Here’s a curious one for you…

Noticed on the weekend, one of the drive LEDs had changed colour…

It was the drive bay for a drive I replaced a little while back, and re-synced OK and all was working fine.

Now the drive LED for bay 3 is sort of half blue and half red… what I mean, is it’s red… ish

It’s not the same red when a drive fails which is clearly red, but it certainly isn’t blue any more, kind of reddish purple.

I’m probably explaining this really bad, but suffice it to say that one of the drive bay’s LED is no longer blue.

I’ve checked the LCD on the front, and all is OK.

I’ve checked via the GUI and all is OK.

I’ve checked the SMART status and all is OK.

I’ve run the disk diagnostics in the tools and all is OK.

I can access the data, so all is OK there too.

BUT… the light on drive bay 3 is no longer blue, but kinda red… sort of.

Any ideas? Or has my EX4 been otherworldly possessed???




Try to reboot the device to see if after rebooting it goes back to normal, this is really strange, also try to take this drive out while the device is off and put the drive in the bay again and turn the device back on. Remember the device must be off when you take the drive out of the bay. 

Hope this helps.

Hi ArMak,

Thanks for the reply…

OK, I shut down the device, removed the drive, waited a minute, then inserted the device and started it up again.

All blue lights during start up, then just before it finished it’s start up, it went red and said volume degraded and started rebuilding.

It said lots of minutes, but I know it lies… it was finished about 10 minutes later and said volumes all good, but the light is still red (sort of blue background) for drive bay 3.

I thought I’d have a look what it said in ssh but now I cannot log into it via ssh.

I tried going into the portal and resetting the password, but no matter what I entered, I was unable to log in via ssh.

So, light is still kind of red, but it still looks like it has the blue LED behind it.

All appears to be working (except for the ssh which is strange), but the light on bay 3 is not blue.

Any other ideas?


OK… update on the ssh permissions thing… this has now been resolved - unrelated brain fade…

red/blue LED issue is still there… cheers.


Have you tried doing a system only restore on the unit ? I suggest contacting support for further assistance on this matter:

What firmware version are you using on your unit?

Have you run a full SMART test on the drive - not just the abbreviated one?

Hi mate,

No, I haven’t tried a full SMART test.

I heard from support and they suggested a system restore as well, so I’ve just done that, and as before all lights were blue right up until it finished it’s startup, then drive 3 went red and after a minute it said volume degraded - rebuilding.  But this time it says 47000+ minutes and has been running more than 15 minutes now and it hasn’t really changed much.

I will probably wait until that rebuild finishes before I do anything else.

Strange that it needed to do a rebuild without me taking a drive out… this tells me that there might be something wrong with the replacement bay 3 drive they sent me a month or so ago.

Let’s see when the rebuild finishes and I’ll run the full test.

I might look up how to speed up the rebuild that someone mentioned on this forum.

Any update on this?  I have the same blue/red light and one drive showing ‘Bad’.  I’m not sure when it started as I stumbled upon it and I don’t appear to have ever received an email alert about it.

Run a full SMART test using the GUI 


Sorry for the late response…

After a week or so of diagnosing with WD support, they came to the conclusion that I should raise an RMA and return the drive.

So I’ve removed and packed up the drive ready for FedEx collection tomorrow.

Concerns me that this is the drive they supplied when the last one failed, so maybe it was a bit off or a “Friday” drive.

Anyhow, lets see what happens when I receive my replacement.  I hope it lasts more than the 3 months this one did, but if it does and then fails, it will be out of warranty… I suppose I’m just lucky all the drives are still under warranty now.

If one of your drives is showing bad, then that’s probably a good sign that one of them is stuffed.

The trouble I had, is that none of them reported as bad or failed or even slightly degraded.

If your drive is under warranty, I’d get an RMA lodged quick and get it replaced, and hope nothing else goes while you wait for the drive to be replaced… It always scares me when you setup a RAID 5 volume to protect your data, and it spends most of it’s time with one drive out.  If another was to go while I was waiting, then I’d be stuffed.

I’m experiencing this exact same problem. Drive 3 failed on my first unit, replaced that drive and the red light stayed on, though all indications were that everything was OK. WD issued an RMA, I moved my drives to the new unit and drive 3 is now red/blue. Again, all indications are that the RAID and drive status are GOOD. I’m not confident that the RAID has completely rebuilt, but I’m very concerned about that red/blue light and what it’s indicating. How did your situation finally resolve?

Hi KevinC22,
Sorry I didn’t put my solution up.
The replacement drive solv d the problem.
Received the new drive, rebuilt the RAID and all lights returned to normal.
Hope your drive is still under warranty. WD are pretty good at swapping them out if they are.

Good luck.

I’ve tried three different drives in that slot, and still have the same problem. Found someplace else on the forum that said you have to format the new drive, but that option is grayed out. I’m sure I’m missing something, but I assumed when I put a replacement drive in the unit, that drive would be formatted and copied to, but it does not seem to be happening on two units so far. First one I only got a red light on Drive 3, second one I get the red/blue light.

Hi mate,
I do recall the same kind of issue with a new drive before. The way I resolved it was to put the drive into an external caddy and connect it to my mac via USB. The mac realised it was a new drive and took me to the disk management utility where I was able to create a new partition on the disk using the full drive size.
Once this was done I put it back into the NAS, turned it on and let it rebuild.
I may have had to addit back into the RAID5 array, but I can’t recall. Have a hunt through my other posts and you’ll find it.
Good luck and let me know how you go.


Thanks for the suggestion. I tried formatting the drive in an external caddy, but that didn’t work either. No sign of the RAID rebuilding. I don’t see how to add it back into the RAID5 array.

Ultimately, I re-striped all drives as RAID5, and will restore my files from a backup (which had it’s own issues; it completely occupies the EX4 so nobody can logon, and never seems to end after 18 hours, even though it’s only backing up 1 TB of data). I can only hope that that backup got everything.

Gotta say this unit is NOT performing as described, in my experience. Tried contacting Support through the portal, but it keeps giving me an error message asking me to “enter a valid model number” even though there is no field for model number.

As you can tell, I’m frustrated, and at this point regretting my purchase, not that that is your problem. I have a Seagate unit that has given me not one ounce of problems, FWIW.

Thanks for your advice.

I was in the same situation and solved.

My configuration is WD mycloud ex4 with 4 hdd in RAID5 (3 + 1 spare drive)

1 disk crashed (red led on HD3)

I’ve replaced the disk and launched the rebuild, when the rebuild has finished the status was Healthy (LCD panel and web admin) but led for HD3 was red and blue at the same time.

My web admin interface is in italian so I’ve translated on-the-fly and some voices may be different:

  • Go to RAID configuration and choose “Change RAID”
  • select the same raid configuration you have in use
  • choose “add spare drive” and next
  • in the next screen you should see the new drive, wait for the auto-verification to complete
  • select the drive and next
  • confirm and proceed with “volume configuration”, it will takes some minutes
  • now the led became fixed blue
1 Like

Do you know that the rebuild “launched”? I couldn’t tell if the automatic rebuild actually happened or not in my case. Everything indicated that the RAID and drives were “good,” but that red/blue light remained on.

As I indicated above, restriping the RAID made all the lights blue. But I still struggle with interminable shut downs and startups and backups that take a day to backup 1 TB. Either I’m doing something horribly wrong or this box does not work as it should. Could be either, I’ll admit. Right now I’m waiting hours to be able to get back into the ADMIN area after a reboot. The blue lights are flashing, the unit sent me an email alerting me that it’s rebooting, but I haven’t been able to access the ADMIN console all day.