Drive disconnects on its own after Lion update

Hi all,

I have three 500GB WD Essential drives WDBACY5000ARDs.  These have always worked fine, then over the weekend I updated to OSX10.7 Lion.  Now my drives won’t stay connected for more than a couple of minutes and the following prompt comes up:

“The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off.”

This happens on all three drives on my MBPro with Lion.  However, the drives work perfectly fine on a second macbook pro I have without Lion on it.  I updated the drives to latest firmware and even installed latest smartware.  The same thing continues to happen.

Any help or advice would be greatly appreciated.

Hi nathanc,

After checking power supplies for the drives and plugs etc…

You might want to check that the settings -> Energy saveing -> Put hard drves to sleep has not changed and if is different between machines.

Also review the About this mac -> More info -> System report -> USB  before and after a disconnect.
Also in the same place
-> Logs -> Kernel logs and Power managment logs.

Might not give you an answer but might provide some insight.

Cheers

Gannett 

Hello,

It seems according to the .pdf below that this unit is not compatible with LION.

http://www.wdc.com/wdproducts/library/AAG/ENG/4178-705131.pdf

Hi, I tried the power management with no luck.  I had tried that already, but I doublechecked just to be sure.  Thanks for the advice though!  I hope I find a solution soon.

Any new news on this issue? I have 3 drives I can’t use with lion that work fine with older mac OSs.  I cant be the only one with this issue.

What if you try with a regular (micro) USB 2.0 cable? It should be more stable than USB 3.0 due to Apple’s neglecting to adopt the technology. Try it out, the Micro USB cable will fit since USB 3.0 is a micro 3.0 with more pins (So the additional pin connector will be empty if you use a 2.0 cable).

Nope! that didnt work either.  Nice try.  Any help would be appreciated, this is really poor.  I can’t access any of my photo collection or Lightroom database.

Any luck on this issue? I’m stuck with 3 drives too!

nope.  For now I gave up and bought a 3TB seagate drive and copied my photo archive to it.