Drive constantly working

You’ll need an SSH client. 

If your on a MAC open a terminal and type in “ssh root@10.0.0.3” change 10.0.0.3 for your myclouds IP Address,

If you don’t know it open a terinal or command prompt, type “ping MyCloud” and hit enter. The reply address that follows will be your devices IP ADDRESS.

Enter the ssh password, Default password for ssh is welc0me.

You’ll be asked something about a key just enter yes and hit enter.

If your on a windows machine download putty, google it its a popular ssh client for windows

once in type top and hit enter it should give you somthing that looks like this.

Thanks for your help.

I see this:

Mem: 496640K used, 12096K free, 0K shrd, 7136K buff, 238880K cached

CPU:  0.5% usr  6.1% sys 93.0% nic  0.0% idle  0.1% io  0.0% irq  0.0% sirq

Load average: 4.82 3.94 2.04 3/196 7097

  PID  PPID USER     STAT   VSZ %VSZ CPU %CPU COMMAND

 4493     1 root     S    47616  9.3   0 92.8 {wdmcserver} /usr/local/wdmcserver

 3777     1 root     S     5280  1.0   0  2.7 system_daemon

 4066  4064 root     S    31520  6.1   0  0.5 /usr/local/twonky/twonkyserver -D

 2537     1 root     R     2272  0.4   0  0.5 up_read_daemon

 6955  6929 root     R     3008  0.5   0  0.2 top

  209     2 root     SW       0  0.0   0  0.2 [kswapd0]

    3     2 root     SW       0  0.0   0  0.2 [ksoftirqd/0]

 3004     2 root     SW       0  0.0   0  0.2 [kworker/0:2]

 3050     2 root     SW       0  0.0   0  0.2 [jbd2/md1-8]

 2421     1 root     S     836m167.9   0  0.0 /usr/local/restsdk/restsdk-server

 4190     1 root     S    70208 13.7   0  0.0 upnp_nas_device -webdir /etc/upnp

 3912  3687 root     S    44064  8.6   0  0.0 httpd -f /usr/local/apache2/conf/h

 3913  3687 root     S    44000  8.6   0  0.0 httpd -f /usr/local/apache2/conf/h

 5597  3687 root     S    43808  8.5   0  0.0 httpd -f /usr/local/apache2/conf/h

 6527  3687 root     S    43424  8.5   0  0.0 httpd -f /usr/local/apache2/conf/h

 5598  3687 root     S    43360  8.5   0  0.0 httpd -f /usr/local/apache2/conf/h

 5591  3687 root     S    43360  8.5   0  0.0 httpd -f /usr/local/apache2/conf/h

 6811  3687 root     S    41760  8.1   0  0.0 httpd -f /usr/local/apache2/conf/h

 4519     1 root     S    41536  8.1   0  0.0 {wdphotodbmerger} /usr/local/wdmcs

 7052  3687 root     S    41312  8.1   0  0.0 httpd -f /usr/local/apache2/conf/h

 3687     1 root     S    40896  8.0   0  0.0 httpd -f /usr/local/apache2/conf/h

 4586     1 root     S    34880  6.8   0  0.0 smbd -D

 4328  4253 root     S    30016  5.8   0  0.0 /usr/libexec/mysqld --basedir=/usr

 4588     1 root     S    18368  3.6   0  0.0 nmbd -D

 4425     1 root     S    16992  3.3   0  0.0 mt-daapd -P /var/run/mt-daapd_daem

 2919     1 root     S    14368  2.8   0  0.0 mail_daemon

 4409     1 root     S    10688  2.1   0  0.0 /usr/local/bin/wdnotifier

 4662  4650 root     S     9568  1.8   0  0.0 /usr/sbin/afpd -d -F /etc/netatalk

 6843  3185 root     S     8064  1.5   0  0.0 sshd: root@ttyp0

 3801     1 root     S N   7840  1.5   0  0.0 /usr/local/orion/communicationmana

 4424     1 root     S     7776  1.5   0  0.0 mt-daapd -P /var/run/mt-daapd_d

CPU:  0.5% usr  6.1% sys 93.0% nic  0.0% idle  0.1% io  0.0% irq  0.0% sirq

This line is interesting your CPU load is at .5% which is nothing but your NIC load is at 93%. My opinion its definitely being accessed by something on the network. Another PC or phone perhaps.

Compare it to my device’s stats and see

CLOUD9:~# top

top - 02:02:26 up 6 days,  3:11,  1 user,  load average: 3.11, 3.15, 3.18

Tasks:   90 total,   1 running,   89 sleeping,   0 stopped,   0 zombie

%Cpu(s):   0.3 us,   0.0 sy,   0.0 ni, 99.7 id,   0.0 wa,   0.0 hi,   0.0 si,   0.0 st

KiB Mem:   232448 total,   169920 used,     62528 free,     7040 buffers

KiB Swap:   500672 total,   103872 used,   396800 free,     33856 cached

  PID USER      PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND           

12619 root      20   0  4352 3392 1408 R   0.7  1.5   0:04.94 top               

    1 root      20   0  2752  832  512 S   0.0  0.4   0:18.26 init              

    2 root      20   0     0    0    0 S   0.0  0.0   0:00.03 kthreadd          

    3 root      20   0     0    0    0 D   0.0  0.0   0:00.00 cpu1_hotplug_th   

    4 root      20   0     0    0    0 S   0.0  0.0   1:19.92 ksoftirqd/0       

    7 root      rt   0     0    0    0 S   0.0  0.0   0:00.00 migration/0       

    8 root      rt   0     0    0    0 S   0.0  0.0   0:00.00 migration/1       

   10 root      20   0     0    0    0 S   0.0  0.0   0:41.52 ksoftirqd/1       

   11 root       0 -20     0    0    0 S   0.0  0.0   0:00.00 khelper           

  214 root      20   0     0    0    0 S   0.0  0.0   0:02.80 sync_supers       

  216 root      20   0     0    0    0 S   0.0  0.0   0:00.08 bdi-default       

  218 root       0 -20     0    0    0 S   0.0  0.0   0:00.00 kblockd           

  224 root       0 -20     0    0    0 S   0.0  0.0   0:00.00 ata_sff           

  235 root      20   0     0    0    0 S   0.0  0.0   0:00.46 khubd             

  241 root       0 -20     0    0    0 S   0.0  0.0   0:00.00 md                

  264 root       0 -20     0    0    0 S   0.0  0.0   0:00.00 rpciod            

  277 root      20   0     0    0    0 S   0.0  0.0   1:36.42 kswapd0           

Well I think I solved the problem, altough i’m not sure what was causing it.

I always have my device “Cloud access” off, except when i’m away for a few days.

For some reason it got activated again whithout me being aware of it. Maybe when I installed WD PHOTOS yesterday since it seems to require it. I didn’t activated it myself… it got activated.

Anyway I turned it back off. The hard drive, and activity lights instantly stabilized.

Strange. The only device who ever accessed it with cloud access was the iphone when I installed WD PHOTOS. But even with plane mode and app uninstalled, the drive keep being busy.

http://community.wd.com/t5/Network-Product-Ideas/The-options-to-disable-the-convert-wdmcserver-wdphotodbmerger/idi-p/712550

I found this in the threads, I think i will benefit you since the WDMCSERVER is what is causing your problem. I missed that earlier sorry.

4493     1 root     S    47616  9.3   0 92.8 {wdmcserver} /usr/local/wdmcserver

all the wd apps, and the wd to go site require the cloud access so yeah by setting up the app it would have turned your cloud features back on. But your issue is the WDMCSERVER and im not sure if thats linked with the cloud featues.

Thanks for the link, I just read it all.

So they said that they implemented a “fix” and that turning cloud access off would shut of this process. 

This is exactly what happens for me.

In case it will start again when I need cloud access, shall I do this 

  1. $ /etc/init.d/wdmcserverd stop
  2. $ /etc/init.d/wdphotodbmergerd stop

?

tks

Well I’m just glad I could be of help, enjoy your MyCloud :smiley: 

Remeber to mark the reply that helped you as a solution so that others with this issue can use your thread for refrence.

Yes, I will mark it as answer.

A question: when the drive is in sleep, should all the led turn off, or do they remain on ?

No, when my devices are in “sleep mode” they display a solid blue light. The MyCloud manual specifies what the different colored and blinking lights mean (manual is posed online on the WD site). If they bother you, you have the option of turning it on in the Dashboard.

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf

look at page 10

wait I think see what your saying the constantly blinking lights in the back? Yeah those are always on and should be on and blinking so long as the mycloud is connected to the network. You want to pay attention to the condition of the light in the front of the device and closely listen to see if the harddrive is spinning. You can also just power the device down completely at night.

No no, don’t worry, I was referring to the front lights and disk spinning. I know the rear lights are network access lights. :stuck_out_tongue:

Thanks for your concern

yeah just look at page 10 of the manual I refrenced ^ 3 replies up it explains it all, page 10 is the 15th page in the pdf

Sleep mode isn’t a solid blue, it’s a slowly pulsing blue, and occurs when the hard disk is actually stopped and parked. Solid blue will have the disk still spinning.

For the indexing and thumbnailing processes, here’s the ‘definitive’ thread:

http://community.wd.com/t5/WD-My-Cloud/Hidden-wdmc-directories-created-by-mcserver-and-photodbmerger/m-p/682091

I know thats what the manual says, but mines alwayes sold blue. And I know for a fact that the drive is parked becuase I’ll wait and hour go back to it try and access it and I’ll hear it spin back up. My light has never pulsed

Yup, my drive always has a solid blue LED too, but the drive seems to be spinning all the time though?

Guys do you know the equivalent of

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

for my cloud mirror ? Can’t yet get an answer in the dedicated forum.

Tks

 I know thats what the manual says, but mines alwayes sold blue.

Okay, but when mine sleeps the HDD, the blue light pulses, and I can feel the HDD is spun down. With solid blue light, I can feel the slight vibration of the spinning drive.

My first disk has a broken blue LED, so I’ve got used to using vibration to check its sleep state…

brakkar

The first two lines stops wdmcsererd and wdphotodbmergerd processes.  The second two lines stop

these two processes from being started on the reboot.  Until you do the last two lines with enable rather than disable.

those two processes will not run again.

RAC