The options to disable the convert, wdmcserver, wdphotodbmerger processes in the My Cloud Dashboard

The process named “convert” in WD My Cloud EX4 causes severe performance and availability problems as well as unnecessary wear of hard drives. After putting many files into the EX4 unit, the convert process begins to consume CPU 100% and cause many unnecessary I/O activities on the hard drives until the owner reboots the unit.

(Update: Firmware 1.02.36 cut CPU consumption down to 40%.)

These severe symptoms have been experienced by many in the community:
http://community.wd.com/t5/WD-My-Cloud-EX4/Why-is-Convert-Process-Maxing-My-CPU/td-p/667863
http://community.wd.com/t5/WD-My-Cloud/Content-scan-never-finishes/td-p/643989

Like many others, I expect EX4 to be a 24x7 reliable storage system with good consistent performance. I do not need media streaming and cloud capabilities. I do not want to waste system resources to have my files analyzed to be classified whether they are videos or photos. I’d be more than happy if EX4 reported 100% of my files classified as “Other” without looking at any of them.

Jumpman has made a good point on wdmcserver and thumbnail generation. If you agree, please also vote at http://community.wd.com/t5/Personal-Cloud-Ideas/Please-don-t-create-WDMC-TWONKY-folders/idi-p/693840

I would like WD to provide the owners of My Cloud EX4/EX2 with the Dashboard options to disable the “convert,” “wdmcserver,” “wdphotodbmerger,” and other processes that generate metadata, thumbnails, and hidden folders so that they will never run again on a future firmware update.

65 Likes

It’s more important they tell us what the actual reason for the convert process running at 100% is.  Also the stupid wdmcserver process causes me this same issue.  Someone mentioned it might have something to do with thumbnail generation.  If so, give us the ability to turn off the thumbnails or whatever is the actual cause. 

I would vote but I don’t see a vote option.

To vote click on the Up arrow icon at the left of the beginning of any post - it’s basically giving a kudos to the post - but it counts as a vote.

Voted. PLEASE fix this!

Hey guys try updating your firmware, mine seemed to resolve the CPU issue cause by those processes.

Upgrading to latest firmware doesn’t solved problem – I had disabled all processes that could benefit from rebuilt thumbnails like iTunes, Twonky, Cloud (only thing I user is RAID 1 with access via CIFS) and despite of disabling almost all features of My Cloud, covert is still building thumbnails (a bit waste of CPU cycles and HDD storage, since I will not use them anyway).

I noticed that when I created encrypted volume without ‘auto-mount’ then (after manually mounting volume) convert process was not working, but since performance of encrypted is questionable I recreated volume as unencrypted, and now convert is killing CPU.

Forgot to mention. Also valid for EX2

I agree – if all the services that use the converted “product” are disabled, the conversion processes should not be run at all.

Yes, PLZ!!

This isn’t really a feature request…

This issue is resolved in our latest code line.  Please update to  1.02.36 

 

http://www.wd.com/wdproducts/updates/?family=wdfmycloud_ex4

We are currently still looking into turning off the convert process.  We will update as we get more information.

Thanks Bill_S for confirming that the option to disable the convert process has NOT yet been implemented in the MyCloud Dashboard at the latest firmware level 1.02.36.

As daytrdr suggested, I’ve updated the firmware to version 1.02.36. I’ve tested my EX4 again by copying 150 photos (.jpg) into the unit. The “convert” process consumed 40% CPU instead of 100%. That is a big improvement.

I’ve also clarified the specific feature I requested in the title of the article.

I have the same problem on my EX2 - although convert seems to be stuck on the same file.

When maxed out, my transfer speed drops from 65MB/s to 8Mb/s which means my backups fail.

Would really like to switch this off - I only want to use the box as a reliable backup device.

I invite all to make reviews in:

Amazon

Newegg

CNET

Bestbuy

and others… 

Maybe it would help WD realize the importance of the situation.

1 Like

I am owner of EX2, and I bought it mainly for photo backup. I bought WD becouse I thought it is a good company, but I must say that by now I am very disapointed that they didn’t fixed this. Especially (looking at this forum) this have high priority for a lot of people.

So how come they improved the issue for EX4 and not EX2? I’m on the latest firmware on an EX2 and still getting 100% CPU with convert…

I have an EX2 also. Firmware is 10.02.08 as of now and it states this is the latest. CPU is usually above 80% usage but it is not constant. .

Struthio: I can tell you, that this device is waaaaaaay better than what I have tested from other companies!! The worst experience I had was with Seagate and believe me, I work with these devices. These small flaws are there, apparently WD doesnt test too much but all-in-all these are working at least. As I see most flaws are security related and can be solved with a soft update. Most other products at this price point doesn’t offer half the services in reality and have loads of hardware flaws. May I suggest you this cool song:  https://www.youtube.com/watch?v=r8OipmKFDeM