Drive becomes unresponsive


I have a WD My Book Essential 3Tb drive, and it used to work for about 6 months properly. Now I have problems. After I plug it into a laptop, it works for several minutes, and then flashing light becomes steady and the drive stops working, Windows Explorer doesn’t see it any more. I tried with a different laptop - same thing. Please help!!!


Please verify the USB cable and if possible connect the drive to a desktop computer, specifically to the USB port located on the back side.

thanks, I will try to get another cable. I don’t have any desktop computers tough, just several laptops, and I tried some of them with the same result.

I have same issue though I have not tested on multiple machines. Mybook non-response… I have a passport that works fine on all usb ports, no issues. What I found out that is interesting is that: With the Mybook, if I short power input (not USB, but power input) for a few seconds, then my Drive is immediately recognized on the next plug-in. (Seems like the input bleed resistor is bad; just a theory!!) This is the second MyBook that I have had these symptoms with.

I Plan to lobby for a Passport to replace; seems to be no issue with Passport.

Best Luck!

well, I still don’t have any desktop available, but I purchased the same exact drive and tokk both USB and power cables from that new one and tried them with my existing drive - same result.

It sounds like there is a problem with the drive or the circuit board. Contact WD about a RMA.


Well, I contacted WD, they offer a replacement. But I’m not interested in replacement, I need access to my data. What would you suggest?

Same problem for me… when i connect my mybook 2TB, it only shows the drive unlock partition and only remain visible for like 30-40 seconds then disconnect and then reconnect automatically… if i press the unlock drive during it’s short visible time it just open but disconnect again after some times… Please  Please give me solution…i dont want replacement… i want my data back… Thanks…