Doesn't play files

Hi guys,

It seems that my HD WD Live can’t play the files from my computer. It does display the files, but it says it can’t play them. When I connect a USB drive with the exact same files, it has no problem at all with playing them. Help?!

Oh, BTW, these files are mostly .avi files.

I’m guessing you’re connecting to your computer via the “Media Servers” option instead of “Network Shares” (Red Button chooses the option.)

If that’s the case, then it sounds like your media server doesn’t support the files.

Nope, my computer is connected via Network Shares…


It might be an access problem, then, rather than a compatibility problem.

Try this:   Install a flash memory stick or portable HD on the USB port of the WDTV.  

Using the WDTV’s Browser User Interface options, COPY the file from your network share to the USB disk.   

Is it able to do that, and then play the new copy off the USB disk?   If so, then I don’t have any idea why it won’t play from the share.

If it is NOT able to do that, then we’ll have to dig deeper.

So I’ve tried what you suggested, but the WD TV Live says it can’t copy the file.

I would bet then that it’s a permissions problem on the server preventing the WDTV from actually opening the file.

How exactly are you accessing these files from the player. Is it video tab / network shares / PC / folder / file.

Have you tried playing music files or photos?

Have you other devices that can access these files and play them.

What operating system is your computer running?

So I wanted to test it again, but now my computer doesn’t appear in the networks share list at all. Then I wanted to try it with an other computer, but this one also doesn’t appear in the list. 

I followed this tutorial:

And now everything works. :slight_smile: