Does not recognize Password

The device will not accept the password.

Since I have continually had problems with the password and this drive, I have done my best to remove user error when creating a password.

I first created the password in notepad, copied it, deleted it, then pasted the passwrod back into notepad and then into the Security app.

I then pasted the password from Notepad into oneNote.

Now it does not accept the password, I am pulling my hair out.

I should have tested it before I left…

I have tried leading and trailing spaces, etc…

Any ideas?

Hi callum.b.marshall,

Which software or protection tool did you use to password protect your My Passport?

However if using WD Security, there is no “forgot password” option to reset the password and the files on the drive are not accessible. But it can be used and reformatted by clicking the Erase button.

I had this issue and almost gave up. So I tried my password a couple more times and then I noticed a message on the screen that said my password was to long. Yes I made my original password one character too long but did not know. So I tried it again leaving one letter off and it worked. So if you have a long password try entering it with the limited length. I think it is 25 characters. Good luck.