Do MyClouds work in an 'non-WWW connected' mode.?

A couple months ago, I bought a 3T MyCloud. COULD NOT GET IT TO WORK in ‘non-WWW connected’ mode.

I’m MCSE with years of tech experience…so tried many different things.

Finally level-2 tech at WD said “hmmmm that’s not right…we’ll send a replacement & comp upgrade to 4T”

Sounded Good :)…was a refurb :frowning:

The 4T came and it acted the exact same way. "Failed to generate code for your mobile device. Please make sure you do not have any network connectivity issues and try again. (250004)

Also…slooooooow transfers (<5MB on internal drive transfer)

Tried Firmware upgrades…on both…no difference.

Seems WD Tech is too busy to respond (busy with that Cloud issue?!!??)

Any ideas?

Well, it would be nice if you list the steps you have taken

  1. make sure you have the latest firmware (it seems you do) but make sure

  2. make sure all network setting for mycloud are working. ie. network is ok, port forwarding is OK.

check this.,487#mcsetup

What does the the dahsboard/cloud access says?

it should say

Connection status conneced

port forwarding connection established.


You MUST have Internet access for Remote Access to work. :slight_smile: if you’re wanting to use the WD App, you at least have to pair it while it has online access.

But once it is paired, I’m not sure if it needs Internet access if you’re just using it within your home net.

what your cloud access screen looks like?

here what it should look like