Do I dare update to 5.06.115?

i am scared.

As well you should be. . . . .

. . . I have not yet loaded 5.06.115, but I probably will over the holiday.
In for a penny; in for a pound as they say.
From what I hear - - > Each of the 5..* updates are an improvement over the earlier 5..* releases.

HOWEVER. . . .if you are still on OS/3 - - -> I would continue to hold out. I suspect 5.06.115 “is not there yet” as a true OS/3 replacement***

NOW MORE THAN EVER. . . . .consider what you would do if your NAS gets bricked. You should have a copy of everything on the NAS somewhere else. That was true before OS/5. . . and remains true now. From my view, I have all critical data on an OS/3 NAS. . . the machine I have on OS/5 is truly experimental. AND I do have a backup of everything on the OS/3 machine.

*** OS/3 vs OS/5 is not a black&white issue. OS/5 does have some good points - - assuming you are not using WD apps

1 Like

I wanted to see too:

SO, I got a new ex2ultra (diskless) pre black Friday for $140 to test.

The first OS5 firmware was a shock – The second firmware was a lot better.
IF you can -play around with OS5 before updating a working OS3 system

You WILL be out a lot of time if other people depend on your system.

My 5 OS3 systems are holding there for now but I do like the new features

2 Likes

Welp… The decision was made for me. WTH, when did I give up my right to decide when or if I upgrade to the latest revision?

1 Like

OS5 seems to be a complete effing disaster. I can’t believe how bad OS5 is compared to OS3, was there even an OS4? Does Western Digital appear to know what they’re doing when they at doing when they rollout such a major change? They have literally rendered my PR4100 32TB RAID 5 (24 usable) useless as a DNLA media server which was its primary purpose.Some of the problems I’ve encountered so far. See the changes here https://support-en.wd.com/app/answers/detail/a_id/29389/related/1

  1. The DNLA feature has been completely removed from the interface menu. It used to reside under Settings->General I think. There was a function to enable or disable the feature via a blue switch. Now there is absolutely nothing to configure. I used to use it to stream directly to my PS4s Media Player. It worked great as long as you had a format playable on PS4. Also used it to stream to my Amazon FireStick via a 3rd party app that functioned as a DNLA/Samba client. This feature also worked great. I have 1000’s of movies downloaded over the years. Neither one now can see the my PR 4100 now. The short term workaround is using my iPad of iPhone OS5 app to stream the movies to my TV via that same 3rd party app on my Firestick that imitates an Apple TV. I loved being able to directly stream using my Sony PS4. So angry about this. Of course I can’t use my phone or iPad while streaming as it will interrupt the playback. There is a suggestion to install Plex or Twonky media servers. 3rd party apps that will have access to my media file. I would have to set up an account to link it through an app available on my Firestick. Are you effing kidding? Admittedly, almost all my movies are torentted. With the DNLA option I had secure streaming with no 3rd party interference. The Plex app has in app purchasing blah, blah. I installed it via the Apps menu under the interface. Sure enough, Plex is much like any other media streaming service, Netflix, Prime HULU etc. I don’t effing want it. Uninstalled and I didn’t create an account. Unless I’m wrong, the DNLA media server option has been completely removed from the login interface. I don’t believe it will function as a DNLA media server anymore. At my wits end I installed Twonky, from the Apps menu under the interface. And poof like magic, I could see my my PR4100 on my PS4 again. Same with the Firestick and probably an Apple TV. No account needed. But is it permanent? On Twonky website https://twonky.com it says I would need a license after 30 days. Is it part of the included software package OS5? Will I be required to pay for something that was built in previously? And yes it works perfectly now. No issues to report. I just wish WD had said mentioned this in the upgrade info. I believe the DNLA feature is one of the most popular reasons for have a Mycloud.
  2. The interface has changed for the worst. Can’t see the media broken down by type, just a single number of available memory left. The previous interface was far more useful. Additionally you could see all attached devices and total number of devices by MAC address. Can’t find that anymore. There are other features under Settings that I believe have been removed.
  3. The os5 my cloud feature seems to be an upgrade and for the most part is an improvement from OS3. There are more things you can do when logged into the website than before.

Before I found a resolution to the DNLA server issue I was pretty upset. I’m not sure I would upgrade to OS5 just yet. It needs a lot more work before it’s truly ready to roll out. Seems like WD engineers have done a poor job, as usual, putting out this upgrade.

4 Likes

Am still at the stage where the EX4100 wont let twonky access it. Am hoping that will fix the problem so my smart TVs can access the info again.

Totally agree that WD have seriously misunderstood the amount who purchased their devices for these purposes.

2 Likes

I don’t agree that the os5 mycloud feature is an upgrade. For me, this element is by far the worst thing about os5. I know it always depends on the use case but just to inform people, here are the most significant issues from my side:

  • Cannot upload files greater than 5GB (this renders it already useless for my work, even without the other issues)
  • In the list view, can’t see either file date/time or file size (ironically, new in os5 is sort by file size, but you can’t see the file size you’ve just sorted by!)
  • Can’t copy only move
  • Can’t move between shares only within share
  • Can’t change file extension when renaming (in OS3 was possible in web portal)
  • Can’t bulk download eg a directory
    PLUS
  • Can’t put a share into the MyCloud portal without endless indexing and reducing drive lifetime (a real own goal, because everyone notices this immediately, whereas many people haven’t noticed / don’t care about the other issues)
  • The uploading being clunky compared to OS3 and seems unreliable in general
  • Several other small things
  • And subjectively for me, the OS3 UI was much more clean and functional
  • I’ll mention one other thing which isn’t for me important, but many people mentioned: Lack of Exif data from pics. But if they start indexing that too…

By the way, many of the other problems people had have been down to the “hardening” of OS5 which in general I agree with, though it should always be possible for a user to opt out.

I think WD should have done the core OS stuff first, then done the whole cloud / indexing thing as a Phase 2. The NAS market is a big growth market but they didn’t do themselves any favours with OS5 so far imo.

The final point: Perhaps WD should do much more to actively (and not just passively) support Docker. This could be a real growth area and also very good for their rep.

4 Likes

Seeing your post ireally wish I had just stuck with OS 3.

2 Likes

I agree with a lot of what you’ve said here. I haven’t tried everything you’ve discussed to verify if it works or doesn’t. So I conducted some tests. Here are a few things I’ve tried in real time.

  • I use a Mac primarily. I can see mycloud under Location, the icon displays it as a computer using MAC finder window. I can access all files just like I would a normal attached HDD drive. So far I’ve had no issues. I dragged a file from one Share to the other and it created a copy in new location. Then you would have to go back and delete the original location. I was able to download or upload from WD to my Mac a 13GB mkv file with no issue. I can see all the file names, extensions, creation dates and file sizes. All this was conducted using Finder while on my local network.

  • I then used the os5mycloudcom web portal. Exactly as you said you cannot move files between shares, make copies, change extensions. Also only information displayed about the file is a date (is that a date of creation or last access?). There is no file size or time stamp. I dragged a 2.05 GB mp4 file and uploaded in successfully, but the 13.58GB mkv file failed.

    I don’t use the web portal that much, but may need to in the future. I will try connecting to my WD from a coffee shop or library to experiment with the web portal some more and see if I can use Finder window remotely (worked previously) as a work around.

  • It sounds like indexing has caused massive downtime and unnecessary wear on the hardware. My indexing took less than 8 hours for a bout 3.6TB of total data. I’ve read here about excessive fan heat, power draw and high internal temps caused by this process while people are unable to access their data, in some cases for days. That could cripple a business.

  • Another issue that hasn’t been mentioned is software shut down issues. I schedule it to shutdown 3 times per week 2-4 am. Sometimes it fails. The next morning I try and access it and it is not showing up in my Finder window. Displayed on the LCD is system shutting down. The process gets hung about 50% of the time. This was true in OS3 and OS5. Same issue occurs frequently when rebooting manually through the UI the process gets hung. This must be a night mare for remote admins who would need to drive to the location and perform a hard reset at the power button.

  • I agree that the NAS market is growing and WD has done such disservice to its customer base which range from amateur users to experienced IT pros. I’m a midlevel user and this is not my first Mycloud. the 4TB Mycloud HDD started to fail. Fortunately, I had enough time to migrate most of my date over. I lost about 20% before the drive would no longer read. Multiple bad sectors. Not impressed this was a supposedly a reliable Red Pro drive. I was leery about upgrading to the PR41000, but seemed to meet my needs at the time and for future data expansion.

My bottom line is this: I’ve seen how poorly WD has executed updates and patches over the years I’ve been with them. OS5 is the final straw for me. When I’m ready to upgrade, I’ll be moving onto Synology.com which sell an equivalent NAS housing and software package. I still have more research to do, but they are focused on NAS housing hardware and enterprise servers. They don’t build drives, but you can use just about any HDD from Seagate, Toshiba and WD amongst others. Systems are far more scalable and price point is equivalent to WD. Supposedly their UI is very functional and their customer support are far better than WD. They have higher reviews and ratings the WD devices. I’m effing done with WD. They should get out of the NAS housing business and focus on just building reliable HDDs. That was their core business for many years. Their customer support, software upgrades and resolutions are inferior to other companies in this market.

2 Likes

When testing, I connected a laptop to phone hotspot to conduct tests.

Note: I would be leary of doing any coffee shop testing without using a VPN connection.

Remember, the backups should have backups!
I use an EX2 with Raid 1. My fear is the board fails, and can’t recover the drives. All the data on my NAS exists elsewhere

I think the truth here is self evident.

Last I looked; the competing enclosures cost notably more than the WD enclosures. . . but still, the bulk of the cost is in the HDD’s. The reduced cost of the enclosures is a false savings in my mind.

So. . in the NAS market, the OS/3 software was woefully obsolete and it took too long to overhaul it.
So. . in the NAS market, the OS/5 software. . . is . . .well. . . . not off to a great start.
So . . in the HDD market, the debacle last year with the CMR/SMR rollout is telling.

@scb99,

Docker used to be the method by which WD supported third party apps and then they released the OS3 SDK and tried to push everyone toward using that instead. There are a few of us that are battling to get Docker to work across all the models where we can with mixed results.

Cheers,

JediNite

@JediNite
That’s very interesting to know thanks. I was completely unaware of that history.
I really wish you luck and hope that WD can see it’s also in their interest to support you. The competitive approach didn’t work for Microsoft against Linux and it certainly won’t for WD against Docker.

1 Like

Do yourself a favor and forget WD. They don’t care about their customers as you can see in many postings here.

Switch to Synology, it’s just a few bucks more but it’s worth, trust me. I have already switched to Synology DS220j, now everything is working fine without any troubles, finally.

2 Likes

I’ll be doing the the same within a years time. Were you able to use your existing WD drives in the new Synology enclosure?

Of course!

Did you have to reformat the drives to use them in the synology?

Yes, Synology is doing it.

Hi Strontium90,

I upgraded to OS/5 and experienced the drives indexing for 5 days continuously (still not done yet). Then I read about the WD40EFRX vs WD40EFAX drives issues. It’s not giving my much confidence to stay with WD.

I see you switched to Synology and you mentioned that you could re-use the WD drives.

I’m seriously thinking of do the same!

I’m just wondering - was it a complicated thing to do? Where would I find info on this? That is - how to migrate away from WD NAS and go to Synology NAS?

I currently have a WD MyCloud EX2 Ultra enclosure with 2 WD40EFRX 4TB drives. It’s in RAID1 config so the data is duplicated on each drive Recently - I bought a third WD40EFRX 4TB drive and was planning to make a copy of my data and keep it physically at another location.

I thinking of how I would to migrate to a Synology system with my new WD40EFRX 4TB drive?

Any suggestions you have - I’d much appreciate it.

Michael

Easiest way: Fork out for another 4TB drive. . … and put both new 4TB drives in the synology enclosure. You really don’t have to have drives of the same brand in a NAS. Heck not even same capacity; although for Raid one. . .get drives of the same capacity. Once the synology is up and running. . . .drag and drop copying will work.

I DO NOT KNOW can set up the synology with raid1 with only one drive. . if you can. . .install it; copy the date over the network. . .then move a drive from the WD to the synology and let it rebuild the drive.

I DO NOT KNOW if you can just pop the drives out of the WD and put it in the synology.

For my money. . . . I would backup the WD NAS to an external drive. . .then just dump the WD drives into the synolgoy and go to town. Another path is to get a USB enclosure, use the WD 4TB in that enclosure as a “roll your own” external drive.

I would just copy all data of the WD NAS to a new hard drive (which can be used as spare drive later), then take out both hard drives of the WD NAS and add them to the Synology NAS, let the Synology format the drives to RAID1 and copy back all data of the spare drive.

And throw the WD NAS out of the window of course!

1 Like