DLNA streaming prevents drive sleep EX4100

I’ve had an EX4100 for about 18 months. Since the last firmware update the array will not stay in sleep mode once I use the streaming media features.

If I reboot the array it will sleep properly, even for days. If I only use file sharing the array continues to behave correctly, but once anything on my network connects to the streaming media service the array will not stay asleep. The drives power up regularly, show access for a few moments, run idle for a while, then go back to sleep. The cycle repeats over and over again, which can’t be good for the drives.

The wake/sleep problem does not go away even if I shut off streaming media in the array’s control panel. Only a reboot will stop it.

I’ve tried changing the drive resample interval in Twonky (-1, 0, etc.) but no change.

I’ve used Wireshark to verify that nothing is connecting to services on the device when it spins up. I have a PR4100 on the same network that doesn’t do this, and the problem has only been present since the last firmware update. In short, it’s a bug.

I’ve seen quite a few other people reporting sleep problems with the EX4100. Is there any hope this will be fixed, or should I just turn off drive sleep and let the drives run 24/7? The constant start/stop has to be increasing wear. If sleep mode won’t be fixed, shouldn’t you remove it?


Mike N.


Have you tried disabling the indexing process? If not, please try that to see if it make any changes.

If you mean the indexing in Twonky, yes I did try that with no effect. Is there another indexing setting I should try?


Mike N.

I found a workaround – if I go on the array’s Twonky page (port 9000) and click “Advanced / Restart Server” after streaming the array will sleep properly. If I stream again the insomnia will return but restarting the Twonky server is much better than rebooting the NAS.

Changing the Twonky sample interval to 0 or -1 or anything else doesn’t prevent the wakeups but restarting the Twonky server with the sample interval set to -1 does fix the problem.

So, if this helps, the problem is in the Twonky server. For me, at least, it was introduced in the April firmware update (2.30.165) – the array did not have this issue before the upgrade.

Hope this helps someone…