Dlna server conflict with airplay

Hi, i’ve recently bought a wd my cloud nas. It works fine on my home network with:
-linksys a1200 wifi router
-marantz mcr603 a network receiver with airplay
-macbook pro

The unique problem is when i turn on dlna server on my cloud, the airplay function stop working. My macbook recognises the Marantz receiver as airplay but when i push play button on macbook after 1s the reproduction stops.
I finally found that disabling dlna server on my cloud airplay starts to work fine like before.
I have the lastest firmware on My cloud.
Any suggestions???

Thanks.

Hi,

Difficult to know why the My Cloud DLNA server is creating this conflict, Check if the receiver has any options to only stream from one media server, you can also try to setup a static IP for the My Cloud and the received to see if that helps.

I have a Denon receiver (same manufacturer as Marantz)

and I have the same problem

And I also got nowhere with WD support

And I also disabled the Icloud DLNA

My belief is that this a Denon bug; once the Denon AVR (or network player - I have a DNP-720AE) starts playback with DLNA, it won’t release the Music Server for Airplay, until you reset the AVR or Network player.

I can repeat this with the WD and Twonky and with JRiver and a PC - it’s the Denon software, trust me.  Power cyclling the Denon resets the network stack and Airplay works just fine, without ever needing to do anything on the Airplay device.

Here’s another thing to try: with your Airplay device, change the playback to the local device (i.e. iPhone or Computer) and then BACK to the Denon.  Sometimes that will work, as long as DLNA playback has stopped.

I also have a Denon (AVR 3311) and have exactly the same problem. Seems to work after I disabled DLNA.

I have exactly the same problem. My Marantz CR603 worked fine with airplay, until I attached my WD MyCloud.

After that Airplay playback stops after 1sec.

Does anybody have a solution other than disabling DLNA on the MyCloud. Because I stream movies from that disk to my TV.

P.

Same here, My Cloud Mirror + Marantz SR 7005 --> no airplay when DLNA is running. 

Try disable WDMyCloud’s DLNA server aka Twonky, then install any good DLNA server software on your PC and have it running. Do you face the same issue?

The same issue in my case with WD Mycloud + DENON RCD-N7

As soon as I have disabled DLNA on WD Mycloud it started working.

I had on PC several DLNA servers like Serviio, PLEX, PS3 Media Server and some other DLNA servers and never had such problem.

Same problem here. Denon RCD-N7 and WD my cloud. 

Only solution is to disconnect WD or disable DLNA.

I have the same problem.

I’ve bought a WD My Cloud 4 TB . It works  on my home network with:
-Netgear wifi router
-Denon Ceol N7 network receiver with airplay
-Two Sonos Play 3.

The unique problem is when I turn on dlna server on My Cloud, the Airplay function in Denon after 1s stops.

Sonos after 1-2 minutes also stop working
I finally found that disabling dlna server on My Cloud(or swich off WD) and restart router, Airplay on Denon and Sonos starts to work fine.
I have the lastest firmware on My WD Cloud.

Pls. inform me if is it any solution for this problem.

P.Mikolajczyk

I also encounter the same problem and symptoms.

WD MY Cloud 4 TB

Zixel Keenetic GIGA II

Marantz Marantz M-CR603

Dune HD mediaplayer

Windows 7 HB

Airplay doesn’t work. I use iTunes on ASUS laptop. When MyCloud is off it works perfectly. When I try to start My Cloud when Marantz is playing in Airplay mode My Cloud doesn’t connect to the network. I tried DHCP and static.  All in vain. When I substitute MyCloud with older MBL - Marantz and ASUS work perfectly in Airplay mode.

Unfortunately no decision has been found yet. No attempts from both or even three - WD, Marantz and  Denon.

http://www.whathifi.com/forum/network-players/airplay-broken-marantz-m-cr603

It would be nice if WD could find the solution, being more advanced in network and pc issues than Marantz/Denon.

I have recently setup a WD MyCloud EX2 and then noticed this same issue with my Marantz MCR603.

Given the age of the first posts on this matter I am not confident anyone (Marantz or WD) will fix the issue. Shame on both of them! Given the newer Marantz CR610 seems to not be affected it is clear Marantz have solved this issue in latter firmware but don’t want the cost of supporting an older model.

Then again WD are not excused as this problem only seems to affect their implementation of the DLNA software.