DLNA Playback problem on some recordings from MythTV .23

Running MythBuntu on a virtual machine, whith a HomeRun HDTV box. All works fine, when I use XBox media center or MythTV itself to playback recordings.

Purchased a WDS Live TV box so I can see the recordings in my livingroom. However - some recordings won’t playback using DLNA, but can play if I play them through the shared files (however hard to find the correct file here).

So playback work on all files using the Samba share - but a lot doesn’t when using DLNA. Someone got a hint how to fix this issue - as I haven’t got a real frontend, only the small WD box?


That is usually caused by the DLNA Server not supporting the file in question.    In that case, the WDTV can’t do anything about it.

I’m having the EXACT same problem.  Did you ever find a solution?  I can’t figure it out… the recordings are made by Myth most will play, but some, recorded off of one specific channel will not through DNLA but will play fine through a samba share.  I can see the recording in DNLA, just get the “blue ring” and it never plays once I try to start it. 

Well, after quite a bit of searching and tinkering… I’ve determined that this occurs due to the OTA broadcast not having the subtitle information in the EIT data.  Myth defaults to using the description as subtitle.  The description is usually a few sentences long which is why the DLNA is rejecting the connection - its way too long.  I can prove this time and time again by using the ubuntu add-on phpmyadmin and editing the ‘recorded’ data in the myth SQL file to be shorter.  The shows play like a charm once the description is shortened. 

There’s some posts online about editing upnpcdstv.cpp with the following data:

line 276:
QString sName = sTitle + ": " + (sSubtitle.isEmpty() ? sDescription :
with this:
QString sName = sTitle + ": " + (sSubtitle.isEmpty() ? “” : sSubtitle);

But my very limited knowledge is that you’d have to recompile the entire myth backend in order to do this.  I haven’t tried it, but given the results of editing the SQL info and having success using the WDTV LIve, I’d say this probably would work. 

Anyone else tried this?  Any pointers for a relatively inexperienced linux user?