DL2100 stopped working 18th December

OK so I have had a DL2100 since 2017 and on the whole has worked pretty seamlessly as Time Machine back up and as storage for photos. However I noted yesterday that it had not backed up since Dec 18th and that Dec 19th WD issued a firmware update.

My suspicion is that this firmware update has created an issue for my NAS, the power button blinks blue slowly and the drives are solid blue. Have tried a short reset and unplugging the device but to no avail. I also note that other users have had similar issues over the years. The most obvious solution would be to unwind the most recent firmware update and go back to the previous state but I have no internet access to the server. I have read elsewhere one can create a start up disk using the USB drive but the solutions don’t cater for MacOS users.

Does anyone have any suggestions. Not totally worried about data as have a full back up but it would be good to get it all working again!!

Hi @petermnorman,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Any news? Got a similar issue with my dl2100.

No and that’s my fault as I simply haven’t had the time to address it so at the moment it is an idle box and I now realise it is over a year since anything was backed up which is not good news!! I need to take up the link provided by Keerti to see if WD can sort the problem otherwise it’s going to be a big investment in a new box.

My boy isn’t that idle, it’s still sticking up power, turning it into heat. Guess I’ll look out for a new device, but I guess not WD. Good luck!

Mine is switched off as was just generating a lot of noise doing nothing. Pretty sure the update was the issue however do need to investigate!!!