Disk status says "Bad" (but all diagnostics say it's not). Please help


#1

I appreciate multiple things are telling me I have a bad disk in my unit, however nothing is telling me what the exact problem is nor what to do. :slightly_frowning_face:

The S.M.A.R.T. data says:

ID
Attribute
Current
Worst
Threshold
1
Raw_Read_Error_Rate
200
200
51
3
Spin_Up_Time
205
198
21
4
Start_Stop_Count
100
100
0
5
Reallocated_Sector_Ct
200
200
140
7
Seek_Error_Rate
200
200
0
9
Power_On_Hours
87
87
0
10
Spin_Retry_Count
100
253
0
11
Calibration_Retry_Count
100
253
0
12
Power_Cycle_Count
100
100
0
16
Unknown_Attribute
244
0
0
183
Unknown_Attribute
100
100
0
192
Power-Off_Retract_Count
200
200
0
193
Load_Cycle_Count
200
200
0
194
Temperature_Celsius
96
88
0
196
Reallocated_Event_Count
200
200
0
197
Current_Pending_Sector
200
200
0
198
Offline_Uncorrectable
100
253
0
199
UDMA_CRC_Error_Count
200
200
0
200
Multi_Zone_Error_Rate
100
253
0

What to do??


#2

Just replace the bad disk with a new drive.


#3

Sorry, I should’ve elaborated.

Despite this warning, everything works fine.

I ran every test within the WD interface, and everything checks out perfect.

I rebooted, and now everything registers as fine.

Are there common causes of a false reading?

Or, is this a sign of things to come?


#4

Hey bbshopplf - I actually ran into the same issue this Friday (March 23rd, 2018.) I have the EX2100 running in RAID 1 (Mirrored) and left it doing a full backup of the primary share since early morning and came home (Friday evening) to find that Drive 1 in my unit was displaying as “Bad”. Did not want to risk losing ANY data, so immediately ordered a spare WD Red 2TB Drive from Amazon which arrived yesterday. Per WD’s suggestion(s) on their FAQ’s I shut-down the unit and removed power. Upon powering it back-up, I was a bit dumbfounded to find that both drives were showing as “Good” again. Ran the FULL Disk Test, System Test and even the Scan Disk function and all passed. I’m still concerned but the S.M.A.R.T. data on both drives looks nearly identical.

I welcome any suggestions as well and would like to see if you have had any further issues since your last post.