Disk not recognized on mac after connecting to pc

Hi, I really hope someone can help me with this problem.

My WD Essential is in FAT32 format (which, as I understand, works both on mac and pc). I normally use this on my mac, which never experienced any trouble at all. However, when I tried to connect it to a friend’s pc the other day, a message showed up requiring me to format the disk, which I chose not to and rejected the disk right away.

Now the disk can’t mount on my mac but still shows up in Disk Utility. I can’t verify, repair nor mount the disk. After some reading in the message board, I understand that I could try to erase the disk using Disk Utility. However, since I’ve been using it as the only backup :frowning: so erasing is not an option.

Disk Description :    WD 3200BMV External Media    Total Capacity :    298.1 GB (320,072,933,376 Bytes)
     Connection Bus :    USB    Write Status :    Read/Write
     Connection Type :    External    S.M.A.R.T. Status :    Not Supported
     Partition Map Scheme :    Master Boot Record


When you connect the drive to the PC, you were able to use it?

I have had the same problem as the one discussed above.  My friend had it connected to a PC for awhile (without my knowledge) and it worked for a bit and then stopped working.  I tried to connect it back into my Mac after having no previous issues, and received an error message “Disk Insertion.  The disk you inserted was not readable by this computer.” with options for “initialize…, ignore, or erase.”  I really can’t erase it as I need the data…any thoughts?